Bug 175345 - anaconda fails to recognize partition table
anaconda fails to recognize partition table
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-09 00:54 EST by Andrew Morton
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-09 07:18:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (9.95 KB, text/plain)
2005-12-09 00:55 EST, Andrew Morton
no flags Details
syslog (19.06 KB, text/plain)
2005-12-09 00:56 EST, Andrew Morton
no flags Details
first 128k of /dev/sda (128.00 KB, application/octet-stream)
2005-12-09 00:57 EST, Andrew Morton
no flags Details

  None (edit)
Description Andrew Morton 2005-12-09 00:54:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031030

Description of problem:
OK, I raised this bug against FC4 but I cannot remember the bug number and I cannot find it in a simple search and I cannot even use my old bugzilla account because the "Forgot my Password" link on your bugzilla login page doesn't do anything.

So I created a new bugzilla account and enjoyed reentering my login into five times as I navigated through the easy_enter_bug pages.  Something is quite screwy in your bugzilla setup.

Now, this bug.

This machine has a workable partition table, but anaconda says "unable to read partition table of /dev/sda".  I'd say that there's something slightly screwy about my partition table which confuses anaconda, but everything else is happy with it.

I'll give you three attachments here - the anaconda log, the syslog and the
first 128k of my /dev/sda.

(getting rather tired of FC1)



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Be me.
2.
3.
  

Additional info:
Comment 1 Andrew Morton 2005-12-09 00:55:57 EST
Created attachment 122064 [details]
anaconda.log
Comment 2 Andrew Morton 2005-12-09 00:56:29 EST
Created attachment 122065 [details]
syslog
Comment 3 Andrew Morton 2005-12-09 00:57:10 EST
Created attachment 122066 [details]
first 128k of /dev/sda
Comment 4 Andrew Morton 2005-12-09 01:04:14 EST
so it appears that anaconda is using parted?

I did parted /dev/sda:

bix:/home/akpm> 0 parted /dev/sda
GNU Parted 1.6.3
Copyright (C) 1998, 1999, 2000, 2001, 2002 Free Software Foundation, Inc.
This program is free software, covered by the GNU General Public License.

This program is distributed in the hope that it will be useful, but WITHOUT ANY
WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.  See the GNU General Public License for more details.

Using /dev/sda
Warning: Unable to align partition properly.  This probably means that another
partitioning tool generated an incorrect partition table, because it didn't have
the correct BIOS geometry.  It is safe to ignore,but ignoring may cause
(fixable) problems with some boot loaders.
Comment 5 Andrew Morton 2005-12-09 01:31:55 EST
OK, so that disk had a funny partition table.  With fdisk:

Disk /dev/sda: 146.8 GB, 146815733760 bytes
255 heads, 63 sectors/track, 17849 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sda1             1        65    522081   83  Linux
/dev/sda2            66     17849 142849980   83  Linux
/dev/sda3   *      1025     17849 135146812+   c  Win95 FAT32 (LBA)

I deleted the win95 partition and parted (and hence anaconda)
seems happy with it.

Only to discover that the fc5-test1 installer appears to have no
way to upgrade an existing install - it appears to insist on wiping
all partitions and repartitioning.  Don't want to do that.

I guess you can kill this bug off.
Comment 6 Paul Nasrat 2005-12-09 07:18:22 EST
Thanks for the report (and the diagnosis).

Yeah FC5 test1 intentionally didn't support upgrades due to large amount of work
being done on anaconda for FC5 (as mentioned in release email) - FC5 test2 will
though.

Note You need to log in before you can comment on or make changes to this bug.