Bug 1753484 - Unwanted WARNING: unable to delete selinux filesystems
Summary: Unwanted WARNING: unable to delete selinux filesystems
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mock
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Raiskup
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-19 05:35 UTC by Remi Collet
Modified: 2019-11-17 04:26 UTC (History)
7 users (show)

Fixed In Version: mock-1.4.21-1.fc30 mock-1.4.21-1.fc29 mock-1.4.21-1.el8 mock-1.4.21-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-06 12:50:49 UTC


Attachments (Terms of Use)

Description Remi Collet 2019-09-19 05:35:39 UTC
Description of problem:
When build failed, and cleanup_on_failure is False, this message appears, even in quiet mode

Version-Release number of selected component (if applicable):
mock-1.4.18-1.fc29.noarch

Comment 1 Pavel Raiskup 2019-11-05 14:09:42 UTC
I've seen this bug before I must say, but I'm not able to reproduce it
now;  both with --old-chroot/--new-chroot.

Can you please check mock-1.4.21 whether the problem still exists?

Comment 2 Pavel Raiskup 2019-11-05 14:14:12 UTC
My guess is that this commit might be the one that fixes the problem:
https://github.com/rpm-software-management/mock/commit/c4eccaed8b41dedf11cc90a94481bcefc4ead2dc

But I'm not able to trigger the situation when mock isn't able to
remove the file it actually created before (supposedly because some
exception is raised at the time when we dropped the privileges from
root to normal user).

If you still see the error, please attach full log and mock
configuration.

Comment 3 Remi Collet 2019-11-05 14:22:12 UTC
mock 1.4.20

ERROR: Exception(/home/rpmbuild/SPECS/remirepo/php/symfony/php-symfony-contracts/php-symfony-contracts-1.1.7-1.remi.src.rpm) Config(fc29x) 0 minutes 11 seconds
INFO: Results and/or logs in: /var/lib/mock/fc29x
ERROR: state finish mismatch: current: rpmbuild php-symfony-contracts-1.1.7-1.remi.src.rpm, state: build phase for php-symfony-contracts-1.1.7-1.remi.src.rpm
WARNING: unable to delete selinux filesystems (/tmp/mock-selinux-plugin.7u_qej23): [Errno 1] Operation not permitted: '/tmp/mock-selinux-plugin.7u_qej23'

mock 1.4.21

ERROR: Exception(/home/rpmbuild/SPECS/remirepo/php/symfony/php-symfony-contracts/php-symfony-contracts-1.1.7-1.remi.src.rpm) Config(fc29x) 0 minutes 12 seconds
INFO: Results and/or logs in: /var/lib/mock/fc29x
ERROR: Command failed: 
 # bash --login -c /usr/bin/rpmbuild -bb --target x86_64 --nodeps /builddir/build/SPECS/php-symfony-contracts.spec

So indeed, issue is fixed,
please add this bug to the bodhi update to I can give it some karma

Comment 4 Fedora Update System 2019-11-05 14:57:55 UTC
FEDORA-2019-c6079af90e has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-c6079af90e

Comment 5 Fedora Update System 2019-11-05 14:58:53 UTC
FEDORA-2019-ad7ecf205b has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ad7ecf205b

Comment 6 Fedora Update System 2019-11-05 14:59:44 UTC
FEDORA-EPEL-2019-3687ce895a has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-3687ce895a

Comment 7 Fedora Update System 2019-11-05 15:00:16 UTC
FEDORA-EPEL-2019-0549ec172d has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-0549ec172d

Comment 8 Fedora Update System 2019-11-06 12:50:49 UTC
mock-1.4.21-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2019-11-10 01:07:10 UTC
mock-1.4.21-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2019-11-17 04:22:45 UTC
mock-1.4.21-1.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-11-17 04:26:29 UTC
mock-1.4.21-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.