Bug 1753562 - pipeline build can't retrive BuildDefaults from builds.config.openshift.io [NEEDINFO]
Summary: pipeline build can't retrive BuildDefaults from builds.config.openshift.io
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Jenkins
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.7.0
Assignee: Akram Ben Aissi
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-19 09:59 UTC by XiuJuan Wang
Modified: 2020-09-22 12:54 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-22 12:54:22 UTC
Target Upstream Version:
erich: needinfo? (abenaiss)


Attachments (Terms of Use)

Comment 1 Adam Kaplan 2019-09-19 13:03:09 UTC
Moving this to Jenkins for further triage. Hypothetically the pods in Jenkins pipelines should be receiving the proxy env vars and pass those along.

Comment 6 Stephen Cuppett 2019-12-13 12:02:14 UTC
Targeting 4.4.0 for investigation on the current master branch.

Comment 7 Akram Ben Aissi 2020-03-12 21:19:37 UTC
Still needs investigation for 4.5

Comment 8 Akram Ben Aissi 2020-06-02 08:56:05 UTC
@Jitendar can you check if you still have this one occuring on 4.4+ ?
as we made changes on the proxy setting propagation this should not occur.
You need an airgapped environment to try to reproduce it.

Comment 9 XiuJuan Wang 2020-06-03 10:05:26 UTC
In the 4.4.0-0.nightly-2020-06-01-211921 proxy cluster,
If don't set workaround [1] for jenkins server, then pipeline build still could reproduce the bug issue.
After set workaround, the pipeline build will meet bug #1813217 issue.

Comment 10 jawed 2020-06-09 10:58:34 UTC
This is not related to jenkins component, this related to the configuration of  build.config.openshift.io/cluster  which is not propagating the proxy env a it should on pod env variables, i guess
th doc here is actually not correct because it is not working https://docs.openshift.com/container-platform/4.2/builds/build-configuration.html
This is related to openshift component
Can someone please assign to the right team
Thank you

Comment 11 XiuJuan Wang 2020-06-10 10:39:28 UTC
In http proxy cluster,common builds could retrive code from github both when build.config.openshift.io/cluster configures proxy to override the global proxy or not. Likewise only pipeline builds don't work.


Note You need to log in before you can comment on or make changes to this bug.