Bug 175359 - Pango has a wrong build requirement on cairo instead of cairo-devel
Pango has a wrong build requirement on cairo instead of cairo-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-09 08:11 EST by Matthias Saou
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-19 12:36:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2005-12-09 08:11:00 EST
In the current FC devel pango, the line :

BuildRequires: cairo >= %{cairo_version}

Needs to be changed to :

BuildRequires: cairo-devel >= %{cairo_version}

Otherwise the package might get built without cairo support, and gtk2
will then refuse to rebuild.
(note that the requirement in the pango-devel sub-package is correct)
Comment 1 Matthias Saou 2005-12-09 08:16:57 EST
Note also that in the spec file, this :

Prereq: libXrender, libX11, libXext, libXft

Is not needed, as those library dependencies will get picked up automatically
by rpm. Since there is no specific version requirement (unlike freetype, gtk2
and cairo here).

One more note, these lines are redundant and the first could be removed :
Prereq: freetype >= %{freetype_version}
Requires: freetype >= %{freetype_version}
(since no %pre scriplet requires stuff contained in freetype)

Maybe you'd be interested in a global spec file patch to clean it all up?
Comment 2 Matthias Clasen 2005-12-09 09:56:31 EST
Sure, a patch would be great. I think the versioned freetype req may be there to
avoid some bugs in older versions, though
Comment 3 Matthias Saou 2005-12-14 05:32:38 EST
While looking some more at the spec file, I started wondering about if there
could be a way to simplify the whole $host and -32/-64 binary install process.
The part that bothers me most is that you end up with a pretty much useless
shell script in %post, since it tests a hardcoded string...

It would be much cleaner to get the "final" $host as an rpm macro in order to
just use it everywhere in the spec (including %post and %files).

Another quick suggestion :
%if %{_lib} == lib64
/usr/bin/pango-querymodules-64
%else
/usr/bin/pango-querymodules-32
%endif

This way, once again, there is no test against the (now) hardcoded $host
made in %post, but instead the correct script is directly called.

Comments? Should I go ahead and try and implement those changes?
Comment 4 Matthias Clasen 2005-12-19 12:36:51 EST
I fixed the cairo buildrequires
Comment 5 Matthias Saou 2005-12-19 12:48:39 EST
OK, I guess you're not too keen taking the risk to break the whole 32/64bit
script thing, which I perfectly understand :-)

Note You need to log in before you can comment on or make changes to this bug.