Bug 175366 - audit performance enhancement patches
Summary: audit performance enhancement patches
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Alexander Viro
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: RHEL4U4Audit
TreeView+ depends on / blocked
 
Reported: 2005-12-09 15:11 UTC by Linda Wang
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-04 13:50:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to help performance in logging path (3.35 KB, patch)
2005-12-09 16:27 UTC, Steve Grubb
no flags Details | Diff

Description Linda Wang 2005-12-09 15:11:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

Description of problem:
Performance issues with audit. With audit, we need to convert all the hook
functions to use an inline function that checks audit_enable and calls the
real audit function only if needed.

Version-Release number of selected component (if applicable):
kernel-2.6.9-22

How reproducible:
Always

Steps to Reproduce:
1.boot the kernel
2.turn audit on
3.
  

Actual Results:  performance degrade drametically

Expected Results:  performance not degrade as much.

Additional info:

Comment 2 Steve Grubb 2005-12-09 16:27:36 UTC
Created attachment 122079 [details]
patch to help performance in logging path

This patch also avoids some uneccessary variable initialization code.

Comment 3 Steve Grubb 2005-12-09 16:37:23 UTC
There was also a technique worked out on the audit mail list to stub the hook
functions with inline functions and call the real audit function if audit is
enabled. It can be found here:

https://www.redhat.com/archives/linux-audit/2005-September/msg00019.html

This code has not been developed. It needs to be since its a simple optimization.


Note You need to log in before you can comment on or make changes to this bug.