Bug 1753665 - error activating gnome-shell -extension dash-to dock
Summary: error activating gnome-shell -extension dash-to dock
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell-extension-dash-to-dock
Version: 31
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-19 14:50 UTC by Héctor Louzao
Modified: 2019-10-30 00:57 UTC (History)
10 users (show)

Fixed In Version: gnome-shell-extension-dash-to-dock-67-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-30 00:57:52 UTC


Attachments (Terms of Use)
picture (10.42 KB, image/png)
2019-09-19 14:50 UTC, Héctor Louzao
no flags Details

Description Héctor Louzao 2019-09-19 14:50:05 UTC
Created attachment 1616771 [details]
picture

Description of problem:

Upgrade from fedora 30 to fedora 31 via DNF

Version-Release number of selected component (if applicable):

gnome-shell-extension-dash-to-dock-66-2.fc31.noarch

How reproducible:

Always

Steps to Reproduce:

1.Try to activated it via gnome-tweaks and check status
2.
3.

Actual results:

doesn't work

Expected results:

don't provide any error in gnome-tweaks and avability to use it

Additional info:

if you point me out in the right direction how to debug a gnome-shell-extension, I could provide more information...

Regards.,

Comment 1 Kurt Bechstein 2019-09-27 03:40:00 UTC
I can also confirm the same behavior on an upgrade to F31 from F30 via DNF.

Comment 2 Andreas Lorenz 2019-10-18 02:47:17 UTC
Can confirm, upstream already has a new version which fixes it (v67).

Comment 3 M. Edward (Ed) Borasky 2019-10-25 03:44:55 UTC
(In reply to Andreas Lorenz from comment #2)
> Can confirm, upstream already has a new version which fixes it (v67).

Is there a package I can test? Or should I just install the upstream version?

Comment 4 Andreas Lorenz 2019-10-25 05:53:37 UTC
(In reply to M. Edward (Ed) Borasky from comment #3)
> (In reply to Andreas Lorenz from comment #2)
> > Can confirm, upstream already has a new version which fixes it (v67).
> 
> Is there a package I can test? Or should I just install the upstream version?

As I am myself new to Fedora, and I got no idea how to notfiy about a new version, I just installed through https://extensions.gnome.org

Comment 5 M. Edward (Ed) Borasky 2019-10-25 05:57:03 UTC
(In reply to Andreas Lorenz from comment #4)
> (In reply to M. Edward (Ed) Borasky from comment #3)
> > (In reply to Andreas Lorenz from comment #2)
> > > Can confirm, upstream already has a new version which fixes it (v67).
> > 
> > Is there a package I can test? Or should I just install the upstream version?
> 
> As I am myself new to Fedora, and I got no idea how to notfiy about a new
> version, I just installed through https://extensions.gnome.org

I tried that ... it's throwing an error but the dash is indeed now a dock.

Comment 6 marco.sarti 2019-10-27 07:45:31 UTC
The version of DashToDock compatible with Gnome 3.34 is version 67, Fedora 31 still distributes version 66.
If you want to have a working DashToDock right away, you must:

- remove the gnome-shell-extension-dash-to-dock package
- install the extension from the site https://extensions.gnome.org/extension/307/dash-to-dock/

Alternatively, wait for the package with version 67.

Comment 7 Michael DePaulo 2019-10-27 09:49:22 UTC
I plan to develop and submit an update to the testing repo within the next week. Possibly tonight.

My apologies for letting this happen to such a commonly used package. I am setting a reminder for every 6 months now. I welcome co-maintainers too.

Comment 8 Fedora Update System 2019-10-27 18:04:45 UTC
FEDORA-2019-27f1434d91 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-27f1434d91

Comment 9 Michael DePaulo 2019-10-28 13:18:25 UTC
Please test ASAP.

https://bodhi.fedoraproject.org/updates/FEDORA-2019-27f1434d91

If 2 more people leave good feedback today via bodhi, I can push it to stable tonight, and it should be ready in time for the F31 release tomorrow.

Comment 10 Victor Toni 2019-10-29 16:03:50 UTC
Not sure if the version made it into Fedora 31.
I forced an update to 31 some hours ago and got stuck when pressing the super key.
It seems all events were caught and didn't went to other applications, means application were not clickable or usable by keys anymore (logging out and in again solved the issue temporarily).

Opened https://extensions.gnome.org/local/ updated the extensions, logged out and in again which solved the issue permanently.

Comment 11 Michael DePaulo 2019-10-29 17:09:47 UTC
@Victor.Toni:

Tomorrow, the only thing that will be necessary is:
sudo dnf update

Because the update is queued for stable tonight.

Today, users should run (per the bodhi link):
sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2019-27f1434d91

They could also update it your way as well. (There are a couple of ways to do it.)

Comment 12 Fedora Update System 2019-10-30 00:57:52 UTC
gnome-shell-extension-dash-to-dock-67-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.