Bug 175383 - [RHEL4] A specific v2.1 Vcard fails to import, entirely silently
[RHEL4] A specific v2.1 Vcard fails to import, entirely silently
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution (Show other bugs)
4.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-09 13:05 EST by Suzanne Hillman
Modified: 2008-02-03 11:59 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-03 11:59:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
v2.1 vcard which won't import into Evo contacts (787 bytes, text/plain)
2005-12-09 13:05 EST, Suzanne Hillman
no flags Details

  None (edit)
Description Suzanne Hillman 2005-12-09 13:05:20 EST
Description of problem:
The attached v2.1 vcard fails to import, with no message telling you that it
didn't work. I suspect a format problem, as I was able to import other v2.1
vcards, but it really ought to _tell_ you that it didn't work (and possibly
why), rather than be quiet about it.

Version-Release number of selected component (if applicable):
evolution-2.0.2-25

How reproducible:
Always

Steps to Reproduce:
1. Open Evolution
2. File -> Import
3. Import the attached file
  
Actual results:
Doesn't import.


Expected results:
Error message explaining that it can't be imported (and why)

Additional info:
Comment 1 Suzanne Hillman 2005-12-09 13:05:20 EST
Created attachment 122084 [details]
v2.1 vcard which won't import into Evo contacts
Comment 2 Dave Malcolm 2005-12-12 23:36:02 EST
Tested with rawhide and it worked:
evolution-2.5.2-1
evolution-data-server-1.5.2-1

Tried on a RHEL4 test box with 
evolution-2.0.2-22
evolution-data-server-1.0.2-9.fix169497.1 (mostly the same as 1.0.2-9)

Worked first time (popped up a contact editor dialog, with a Cancel button but
an insensitive Ok button), having cancelled I'm seeing similar symptoms on
subsequent attempts.
May well be affected by file type detection; did you select Automatic or VCard
in step 3?
Comment 3 Suzanne Hillman 2005-12-13 10:08:50 EST
I don't recall. I'd only have specfied which kind of file type if it couldn't
figure it out on my own, I think.
Comment 4 Matthew Barnes 2008-02-03 11:25:47 EST
Evolution 2.0.2 is only being updated for security issues.  Closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.