Bug 175392 - Should provide better error messages during db2ldif
Should provide better error messages during db2ldif
Status: CLOSED WORKSFORME
Product: 389
Classification: Community
Component: Database - Import/Export (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Noriko Hosoi
Orla Hegarty
:
Depends On:
Blocks: 152373 240316
  Show dependency treegraph
 
Reported: 2005-12-09 13:36 EST by Steve Parkinson
Modified: 2007-05-16 09:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-04 14:26:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Parkinson 2005-12-09 13:36:30 EST
During db2ldif, I get these errors:


[01/Dec/2005:12:54:49 +0000] - add value for type revinfo failed: duplicate value
[01/Dec/2005:15:20:08 +0000] - add value for type revokedby failed: duplicate value
...
[02/Dec/2005:01:18:23 +0000] - Processed 1245000 entries.
[02/Dec/2005:01:18:24 +0000] - add value for type uniquemember failed: duplicate
value
[02/Dec/2005:01:18:28 +0000] - Processed 1246000 entries.


(this may have been addressed in a new version of directory server - I was
seeing these message in DS 4.12)

The problem is that it is very difficult to determine the entry that is causing
the problem. I would like to see the DN in each case.
Comment 1 Noriko Hosoi 2005-12-13 21:52:36 EST
The error message is issued when adding an entry with multiple same valued
attribute or adding an attribute to an entry that already has the attribute
value.  I'm curious what kind of operation was under way at that time... 
(please note that db2ldif never modifies entries)

The error message had been improved as follows since DS6.2:
  add value "testuser@redhat.com" to attribute type "mail" in entry "cn=Test
User, dc=redhat, dc=com" failed: value exists
Comment 2 Noriko Hosoi 2006-12-04 14:26:33 EST
There was a bug in 7.1:
164843: deleting subtyped attribute value problem.

Identical attribute type, value pairs were allowed to be in an entry.
> Mail:xyz
> Mail:xyz

This bug was fixed since 7.1 sp1:
  A client can provide multiple attributes with the same attribute type 
  and value, only if those attributes are language sub-types
  This means that the following is allowed:
    attrA: valueA
    attrA;lang-en: valueA

So, there is no chance to reproduce the problem.  But as noted in Comment #1,
the corresponding error message prints out the dn value.

Note You need to log in before you can comment on or make changes to this bug.