Bug 1753941 - [metric] Information how to enable verbose mode for scripts
Summary: [metric] Information how to enable verbose mode for scripts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-metrics
Version: 4.3.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-4.3.7
: 4.3.7
Assignee: Shirly Radco
QA Contact: Ivana Saranova
URL:
Whiteboard:
Depends On:
Blocks: 902971 1754244 1767344
TreeView+ depends on / blocked
 
Reported: 2019-09-20 10:34 UTC by Olimp Bockowski
Modified: 2020-03-09 13:46 UTC (History)
6 users (show)

Fixed In Version: ovirt-engine-metrics-1.3.5.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1754244 (view as bug list)
Environment:
Last Closed: 2019-12-12 10:36:34 UTC
oVirt Team: Docs
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:4229 0 None None None 2019-12-12 10:37:02 UTC

Internal Links: 1754244

Description Olimp Bockowski 2019-09-20 10:34:31 UTC
Description of problem:
In "Metrics Store Installation Guide" there is no info on how to debug problems.

In both sections:
2.1. Create the Metrics Store virtual machines / Create Metrics Store virtual machines / Point 2 (Run the ovirt-metrics-store-installation playbook to create the virtual machines)

2.2. Deploy Metrics Store services on Red Hat OpenShift / Procedure / Point 2 

There should be info (as NOTE for example), how to enable more verbose output in: ovirt-engine-metrics version 1.3.3.3
 
so the command should be prefixed with either:
ANSIBLE_VERBOSITY=X , where is is 2, 3 or 4 

JUSTIFICATION:
We can't assume someone who reads knows Ansible well and even he knows we are running the script what makes it more complicated.

MORE INFO:
when we run 
./configure_ovirt_machines_for_metrics.sh  --help 
there is no info how to enable debug, putting there -vvv doesn't work. Apart from env variable, one could edit script and put "-vv \" in line 123

--- ./configure_ovirt_machines_for_metrics.sh
+++ ./configure_ovirt_machines_for_metrics.v2.sh
@@ -122,0 +123 @@
+	-vv \

Comment 1 Shirly Radco 2019-09-22 07:28:48 UTC
Add to the following commands -vvv :

1. ANSIBLE_JINJA2_EXTENSIONS="jinja2.ext.do" ./configure_ovirt_machines_for_metrics.sh --playbook=ovirt-metrics-store-installation.yml --ask-vault-pass

should be 
ANSIBLE_JINJA2_EXTENSIONS="jinja2.ext.do" ./configure_ovirt_machines_for_metrics.sh --playbook=ovirt-metrics-store-installation.yml --ask-vault-pass -vvv

2. ANSIBLE_CONFIG="/usr/share/ansible/openshift-ansible/ansible.cfg" \
  ANSIBLE_ROLES_PATH="/usr/share/ansible/roles/:/usr/share/ansible/openshift-ansible/roles" \
  ansible-playbook -i integ.ini install_okd.yaml -e @vars.yaml -e @secure_vars.yaml --ask-vault-pass

should be

ANSIBLE_CONFIG="/usr/share/ansible/openshift-ansible/ansible.cfg" \
  ANSIBLE_ROLES_PATH="/usr/share/ansible/roles/:/usr/share/ansible/openshift-ansible/roles" \
  ansible-playbook -i integ.ini install_okd.yaml -e @vars.yaml -e @secure_vars.yaml --ask-vault-pass -vvv

or add a comment about the option of adding verbose mode, by adding -vvv to the commands.

-v, --verbose
verbose mode (-vvv for more, -vvvv to enable connection debugging)

Comment 2 Olimp Bockowski 2019-09-23 08:14:39 UTC
Indeed -vv or -vvv works, 

Name        : ovirt-engine-metrics
Version     : 1.3.3.3

I used env variable ANSIBLE_VERBOSITY becuase I was pretty sure "-vv" hadn't worked in previous versions?

Comment 7 Ivana Saranova 2019-11-08 14:29:56 UTC
Verbose mode is working and verified in another bug:  BZ 1715519
Separate doc bug was created: BZ 1754244
Therefore I'm verifying this bug based on the previous verification and no indication of regression.

Comment 9 errata-xmlrpc 2019-12-12 10:36:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4229


Note You need to log in before you can comment on or make changes to this bug.