Bug 175395 - Font packages should not be dependent on any other packages.
Font packages should not be dependent on any other packages.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fonts-chinese (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-09 13:56 EST by Ron
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-23 02:32:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ron 2005-12-09 13:56:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
Installing fonts-chinese also installs chkfontpath, ttmkfdir, xorg-x11-font-utils, and xorg-x11-xfs.

This should not be required, since TrueType fonts can be used for things other than X11, for example PHP scripts running on Linux servers that are not even running X11.

It should be possible to install any of the fonts-* packages without requiring that any other package be installed.

Please remove all dependencies from all fonts-* packages.

This also points to a larger problem of unneded/unwanted dependencies throughout FC4.  A review of the entire dependency chart is needed, eliminating all dependencies which are not absolutely necessary.  For example, a similar bug exists with OpenOffice and libgcj.  Because the counterfeit libgcj interferes with REAL Java(TM) from Sun Microsystems, installing OpenOffice makes it incredibly difficult to run real Java on the same system.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install a system without X11
2. Run "yum install fonts-chinese"
3. Note that it also wants to install additional packages, which are not wanted on a non-X11 Linux server.


Additional info:
Comment 1 Leon Ho 2006-01-09 01:10:15 EST
The main problem is that because it is postinstall running chkconfig,and
ttmkfdir. We can make it optional to run those command, but it won't work on any
native X package if the user install X later.

As this is a general font package bug, I am going to assign it to our i18n
engineer, Tagoh-san for getting more input
Comment 2 Akira TAGOH 2006-01-10 06:11:36 EST
well, I'm just curious though, how does that PHP script use TrueType font? isn't
it on the client side but not on the server side?
Comment 3 Ron 2006-01-10 11:45:36 EST
PHP scripts, running under Apache, can use any TrueType fonts that exist on the
server.  This is typically used for generating dynamic images that are served
over the web, and this is fully supported by PHP.

But this is not only an issue regarding TrueType fonts and PHP.  X is not the
only piece of software that will ever use TrueType fonts.  All kinds of
software, both client- and server-side will use TrueType fonts, and these font
should be installable and usable without requiring the addition of any additioal
packages except for the font packages that are needed by whatever application is
using fonts.

Again, this points to the overly tight coupling between packages in Fedora (and
Red Hat) Linux distros, and gives other distros a significant advantage.  There
are lots of artificial dependencies between packages in all of the Fedora and
Red Hat distros, and this is just another example.  This mentality of
over-dependence between packages has been an epidemic since at least Red Hat 7.  

The main point of this bug report is that one should be able to simply install
the font RPMs that are needed, regardless of the application that is using them,
without being forced to install other unwanted RPMs (chkfontpath, ttmkfdir,
xorg-x11-font-utils, and xorg-x11-xfs).  This is especially true in a server
environment, where we don't need or want a GUI (X) or any of its components. 
The justifications are numerous, including security and ease of management. 
These are very reasonable concerns, and should be accommodated by simply
removing the dependencies, allowing the fonts to be installed independently of
any other packages.
Comment 4 Akira TAGOH 2006-01-11 01:57:10 EST
Yes, I'm not saying to reject this at all though, was trying to find the way out
to get this working.  I however can't do remove all dependencies without any
thoughts you know because it will causes the problems related to X and current
dependencies were needed to ensure its working - creating a fonts.dir, adding a
font path to xfs , updating fontconfig cache and so on. since these TrueType
fonts were basically used for the desktop in our distro.

So we need to think about an idea not to make any regressions on this anyway.
Comment 5 Akira TAGOH 2006-01-19 00:21:41 EST
We need to do something like what we did in %post/%postun right now because it's
necessary to ensure that the fonts can be used for X anyway. otherwise people
will complain like 'I have installed fonts-chinese package. but I can't see any
characters on my X application at all.' because of fonts-chinese will be going
to do nothing at %post/%postun for this problem then. AFAICT only the way to do
it without depending on other packages is, it uses %trigger. but using %trigger
is terrible. you may see the problem when triggered packages is renamed and so
on. I'm trying to find another way out to fix this problem now. if you have any
idea, please let us know.
Comment 7 Akira TAGOH 2007-08-13 00:26:43 EDT
just For updates, since we are getting rid of xfs, we could also get rid of the
dependencies after that so that we don't need to worry about updating fonts.dir
at the runtime and can just generate it at the build time then.
Comment 8 Jens Petersen 2007-10-23 02:32:59 EDT
This is fixed in the new packages for F8 I believe.

Note You need to log in before you can comment on or make changes to this bug.