Bug 1753970 - /var/log/dnf.rpm.log contains duplicate entries
Summary: /var/log/dnf.rpm.log contains duplicate entries
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: dnf
Version: 8.0
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: rc
: 8.0
Assignee: Jaroslav Mracek
QA Contact: Luca Berton
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-20 11:49 UTC by Jan Blazek
Modified: 2020-04-28 16:48 UTC (History)
4 users (show)

Fixed In Version: dnf-4.2.11-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:48:13 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1823 None None None 2020-04-28 16:48:54 UTC

Description Jan Blazek 2019-09-20 11:49:46 UTC
Description of problem:
/var/log/dnf.rpm.log contains duplicate entries for single operations done by dnf.

2019-09-20T11:42:08Z INFO --- logging initialized ---
2019-09-20T11:42:09Z SUBDEBUG Installed: dummypkg-1-1.noarch
2019-09-20T11:42:09Z SUBDEBUG Installed: dummypkg-1-1.noarch
2019-09-20T11:42:10Z INFO --- logging initialized ---
2019-09-20T11:42:10Z SUBDEBUG Erase: dummypkg-1-1.noarch
2019-09-20T11:42:10Z SUBDEBUG Erase: dummypkg-1-1.noarch

Version-Release number of selected component (if applicable):
dnf-4.2.7-6.el8.noarch
libdnf-0.35.1-8.el8.x86_64

How reproducible:
always

Steps to Reproduce:
# yum -y install dummypkg
# yum -y remove dummypkg
check the last entries in /var/log/dnf.rpm.log

Actual results:
Every SUBDEBUG message is present twice.

Expected results:
Every SUBDEBUG should be present just once.

Additional info:
This is a follow-up of bug 1695720.

Comment 1 Pavla Kratochvilova 2019-09-23 11:36:10 UTC
Fixed in upstream, PR: https://github.com/rpm-software-management/dnf/pull/1463
Tests in ci-dnf-stack: https://github.com/rpm-software-management/ci-dnf-stack/pull/595

Comment 7 errata-xmlrpc 2020-04-28 16:48:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1823


Note You need to log in before you can comment on or make changes to this bug.