Bug 175409 - Reproducible crash on Word document (table issue?)
Reproducible crash on Word document (table issue?)
Status: CLOSED DUPLICATE of bug 173798
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-09 16:30 EST by Mary Ellen Foster
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-12 03:39:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 5125 None None None Never

  None (edit)
Description Mary Ellen Foster 2005-12-09 16:30:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
I have a Word document that reproducibly crashes OpenOffice.org every time I open it. Unfortunately, I can't attach it to this bug report, as it's somewhat private; however, I can send it directly to a developer if necessary.

It was suggested on fedora-test-list that this could be related to tables; certainly, the document does contain tables.

I'll post the backtrace from the crash in a separate comment in an effort to make bugzilla not barf on this bug ...

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.0.1-143.1.2

How reproducible:
Always

Steps to Reproduce:
1. openoffice.org-2.0 filename.doc

Actual Results:  Crash

Expected Results:  Opening the document

Additional info:
Comment 1 Mary Ellen Foster 2005-12-09 16:31:57 EST
Here's the back trace (will this work?):

                                                                               
                                                                               
                                                                               
               
Video Driver is probably nv
DESKTOP_SESSION is set to kde
libgcj version is libgcj-4.0.2-6
OpenOffice.org core rpm version is openoffice.org-core-2.0.1-143.1.2
0x368e940: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e940
0x368f145: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1f145
0x121420:  + 0x420 (__kernel_sigreturn + 0x0)
0xbf5c68: /lib/libc.so.6 + 0x29c68 (abort + 0xf8)
0xc29a30: /lib/libc.so.6 + 0x5da30 (__libc_fatal + 0x0)
0xc2f8e0: /lib/libc.so.6 + 0x638e0
0xc2ffa2: /lib/libc.so.6 + 0x63fa2 (__libc_free + 0x79)
0x99f953: /usr/lib/libX11.so.6 + 0x2e953 (XPolygonRegion + 0xc38)
0x146f1c: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x24f1c
(X11SalGraphics::drawPolyPolygon(unsigned long, unsigned long const*, SalPoint
const**) + 0x6a)
0x3d57283: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x155283
(SalGraphics::DrawPolyPolygon(unsigned long, unsigned long const*, SalPoint
const**, OutputDevice const*) + 0xbb)
0x3cef9e1: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xed9e1
0x3cf22c2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xf02c2
(OutputDevice::DrawPolyPolygon(PolyPolygon const&) + 0x180)
0x3cdcc44: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xdac44
(MetaPolyPolygonAction::Execute(OutputDevice*) + 0x1e)
0x3cbddd9: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xbbdd9
(GDIMetaFile::Play(OutputDevice*, unsigned long) + 0xad)
0x3cc1995: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0xbf995
(GDIMetaFile::Play(OutputDevice*, Point const&, Size const&, unsigned long) + 0x1bb)
0x426b865: /usr/lib/openoffice.org2.0/program/libgo680li.so + 0x5f865
(GraphicManager::ImplDraw(OutputDevice*, Point const&, Size const&, GDIMetaFile
const&, GraphicAttr const&) + 0x121)
0x426ba96: /usr/lib/openoffice.org2.0/program/libgo680li.so + 0x5fa96
(GraphicManager::ImplCreateOutput(OutputDevice*, Point const&, Size const&,
GDIMetaFile const&, GraphicAttr const&, unsigned long, GDIMetaFile*) + 0x216)
0x426d3ce: /usr/lib/openoffice.org2.0/program/libgo680li.so + 0x613ce
(GraphicManager::ImplDraw(OutputDevice*, Point const&, Size const&,
GraphicObject&, GraphicAttr const&, unsigned long, unsigned char&) + 0x17a)
0x426d62d: /usr/lib/openoffice.org2.0/program/libgo680li.so + 0x6162d
(GraphicManager::DrawObj(OutputDevice*, Point const&, Size const&,
GraphicObject&, GraphicAttr const&, unsigned long, unsigned char&) + 0x1cb)
0x42672c5: /usr/lib/openoffice.org2.0/program/libgo680li.so + 0x5b2c5
(GraphicObject::Draw(OutputDevice*, Point const&, Size const&, GraphicAttr
const*, unsigned long) + 0x253)
0x8dd1354: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x380354
0x8dd2493: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x381493
0x8d07541: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2b6541
0x8d084e3: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2b74e3
0x8d49f9c: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2f8f9c
0x8d45007: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2f4007
0x8d3425b: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2e325b
0x8d07541: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2b6541
0x8d07541: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2b6541
0x8d089b0: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x2b79b0
0x8c2583d: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1d483d
(ViewShell::Paint(Rectangle const&) + 0x239)
0x8c040fc: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1b30fc
(SwCrsrShell::Paint(Rectangle const&) + 0x70)
0x906231a: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x61131a
0x3dd1b98: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1cfb98
0x3dd1c55: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1cfc55
0x3dd1c55: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1cfc55
0x3dd1c55: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1cfc55
0x3dd1c55: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1cfc55
0x3dd1e73: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1cfe73
(Window::Update() + 0x191)
0x8c25ee0: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1d4ee0
(ViewShell::VisPortChgd(SwRect const&) + 0x4f0)
0x8c041f5: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x1b31f5
(SwCrsrShell::VisPortChgd(SwRect const&) + 0x77)
0x9119f72: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x6c8f72
(SwView::SetVisArea(Rectangle const&, unsigned char) + 0x216)
0x911a1ec: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x6c91ec
(SwView::DocSzChgd(Size const&) + 0xbc)
0x9107f25: /usr/lib/openoffice.org2.0/program/libsw680li.so + 0x6b6f25
(SwView::Activate(unsigned char) + 0x5b)
0x5369b83: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1b1b83
(SfxShell::DoActivate(SfxViewFrame*, unsigned char) + 0x2d)
0x536143a: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1a943a
0x53442d1: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x18c2d1
(SfxViewFrame::DoActivate(unsigned char, SfxViewFrame*) + 0x2d)
0x52751b1: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xbd1b1
(SfxApplication::SetViewFrame(SfxViewFrame*) + 0x179)
0x5346d64: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x18ed64
0x5346fdd: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x18efdd
(SfxViewFrame::Show() + 0x14d)
0x5353f27: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x19bf27
(SfxTopFrame::InsertDocument(SfxObjectShell*) + 0x807)
0x5336deb: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x17edeb
0x5585421: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xeb421
0x5585c13: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xebc13
0x55861d8: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0xec1d8
0x54d81cd: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x3e1cd
0x69c8449: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x34449
(desktop::DispatchWatcher::executeDispatchRequests(_STL::vector<desktop::DispatchWatcher::DispatchRequest,
_STL::allocator<desktop::DispatchWatcher::DispatchRequest> > const&) + 0x1027)
0x69c1737: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x2d737
(desktop::OfficeIPCThread::ExecuteCmdLineRequests(desktop::ProcessDocumentsRequest&)
+ 0x129)
0x69b8551: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x24551
(desktop::Desktop::OpenClients() + 0xdd9)
0x69b867d: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x2467d
(desktop::Desktop::OpenClients_Impl(void*) + 0x33)
0x69b86d4: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x246d4
(desktop::Desktop::LinkStubOpenClients_Impl(void*, void*) + 0x1a)
0x3c8524c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8324c
0x3ddf286: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1dd286
0x140ffa: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x1effa
0x1678fa: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x458fa
(SalDisplay::DispatchInternalEvent() + 0xb0)
0x428419: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x19419
0x469a38f: /usr/lib/libglib-2.0.so.0 + 0x2538f
0x4698137: /usr/lib/libglib-2.0.so.0 + 0x23137 (g_main_context_dispatch + 0x1d7)
0x469b12c: /usr/lib/libglib-2.0.so.0 + 0x2612c
0x469b5be: /usr/lib/libglib-2.0.so.0 + 0x265be (g_main_context_iteration + 0x62)
0x42803f: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x1903f
0x168b1e: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x46b1e
(X11SalInstance::Yield(unsigned char) + 0x28)
0x3c8b50c: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8950c
(Application::Yield() + 0x48)
0x3c8b542: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x89542
(Application::Execute() + 0x26)
0x69b9ca0: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x25ca0
(desktop::Desktop::Main() + 0x15c6)
0x3c90907: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e907
0x3c909b7: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e9b7 (SVMain()
+ 0x29)
0x69b1233: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1d233 (sal_main
+ 0x57)
0x69b127f: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1d27f (main + 0x27)
0xbe162f: /lib/libc.so.6 + 0x1562f (__libc_start_main + 0xdf)
0x80484a5: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x4a5

Comment 2 Caolan McNamara 2005-12-12 03:39:42 EST
I know this one alright, the backtrace is good enough to point to the problem.
It's not an openoffice.org bug, but one in X. See
https://bugs.freedesktop.org/show_bug.cgi?id=5125

*** This bug has been marked as a duplicate of 173798 ***

Note You need to log in before you can comment on or make changes to this bug.