Bug 1754129 - gdeploy fails to install in Fedora rawhide (requires PyYAML)
Summary: gdeploy fails to install in Fedora rawhide (requires PyYAML)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdeploy
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Sachidananda Urs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2019-09-20 22:55 UTC by Miro Hrončok
Modified: 2020-05-11 06:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-11 06:58:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2019-09-20 22:55:33 UTC
gdeploy-2.0.8-3.fc29.noarch fails to install in Fedora rawhide:

  nothing provides PyYAML needed by gdeploy-2.0.8-3.fc29.noarch

This is caused by using the unversioned Python name.

Please either depend on python3-pyyaml or python2-pyyaml explicitly. Thanks

Comment 1 Miro Hrončok 2019-10-03 21:33:27 UTC
Error: 
 Problem: conflicting requests
  - nothing provides PyYAML needed by gdeploy-3.0.0-2.noarch

Comment 2 Sachidananda Urs 2019-10-04 03:48:43 UTC
(In reply to Miro Hrončok from comment #1)
> Error: 
>  Problem: conflicting requests
>   - nothing provides PyYAML needed by gdeploy-3.0.0-2.noarch

Ack. I will fix this and do a rebuild. Thanks.

Comment 3 Sachidananda Urs 2019-10-05 03:56:39 UTC
(In reply to Sachidananda Urs from comment #2)
> (In reply to Miro Hrončok from comment #1)
> > Error: 
> >  Problem: conflicting requests
> >   - nothing provides PyYAML needed by gdeploy-3.0.0-2.noarch
> 
> Ack. I will fix this and do a rebuild. Thanks.

I have made a new build changing the package name to python3-pyyaml

Comment 4 Ben Cotton 2020-02-11 17:53:20 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 5 Igor Raits 2020-05-11 06:58:53 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (ignatenkobrain@fedoraproject.org).

All subpackages of a package agaisnt which this bug was filled are now installable or removed from Fedora 32.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.