Bug 1754167 - FEDORA-MODULAR-2019-ca0457e593 Mako package has broken dependencies on F30
Summary: FEDORA-MODULAR-2019-ca0457e593 Mako package has broken dependencies on F30
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Modules
Classification: Fedora
Component: sway
Version: unspecified
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Till Hofmann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-21 12:26 UTC by grumpey0
Modified: 2019-11-07 09:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-07 09:27:46 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description grumpey0 2019-09-21 12:26:17 UTC
Description of problem:
FEDORA-MODULAR-2019-ca0457e593, Mako package has broken dependencies for Fedora 30. 

During sudo dnf upgrade: 
Problem: cannot install the best update candidate for package mako-1.4-1.module_
  - nothing provides libsystemd.so.0(LIBSYSTEMD_243)(64bit) needed by mako-1.4-1.module_f32+6140+eb754d2b.x86_64

Package is skipped due to broken dependencies.  

Version-Release number of selected component (if applicable):
FEDORA-MODULAR-2019-ca0457e593, Mako 1.4-1.module_f32+6140+eb754d2b

How reproducible:
Always

Steps to Reproduce:
1.sudo dnf upgrade 
2.
3.

Actual results:
Mako fails to update. 
https://paste.fedoraproject.org/paste/pB3P-YC4TDTaSjghixXHug
Expected results:
All packages in Module update. 

Additional info:

Comment 1 Till Hofmann 2019-09-22 09:31:41 UTC
This looks like an odd issue with modules: The package version clearly indicates that this is in fact a F32 package, not a F30 package.

The modulemd file of the F30 build [1] also contains a bunch of F32 packages.

I'll ask on @devel as I have no idea what may be causing this

[1] https://kojipkgs.fedoraproject.org//packages/sway/rolling/3020190912072731.a5b0195c/files/module/modulemd.x86_64.txt

Comment 3 grumpey0 2019-09-22 23:38:34 UTC
Thanks, and THANKS for maintaining this.


Note You need to log in before you can comment on or make changes to this bug.