Bug 175428 - [FC4] innetgr memory leak on netgroup lookup failure
[FC4] innetgr memory leak on netgroup lookup failure
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-09 22:44 EST by Andrew Schretter
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.3.6-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 14:54:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Schretter 2005-12-09 22:44:31 EST
Description of problem:

rpc.mountd leaks memory when using a netgroup in /etc/exports.
On one system it leaked about 1MB every 7 minutes which caused
the system to kill the process about once every 2 weeks or so
when it gets past 2GB of memory usage.

No memory leak is detected if the netgroup is replaced by a listing
of hosts or ip ranges, rpc.mountd stays around 2.5 MB memory usage.

I think the problem is a documented one in the innetgr function in glibc 
and fixed in a rawhide/FC5 release :

http://sources.redhat.com/ml/libc-hacker/2005-09/msg00031.html

But it would be REALLY nice to roll a FC4 update for glibc with this
small patch in.  It would appear to affect all applications that access
netgroup for host permissions


Version-Release number of selected component (if applicable):
glibc-2.3.5-10.3

How reproducible:
Always

Steps to Reproduce:
1.Create a valid /etc/netgroup file
2.Add the netgroup to an NFS export in /etc/exports
3.Start NFS server and try lots of mounts, unmounts, failed mounts, etc
  
Actual results:
rpc.mountd memory usage grows unnecessarily

Expected results:
rpc.mountd should not grow more than to a few megabytes or memory usage

Additional info:
Comment 1 Jakub Jelinek 2006-03-15 14:54:35 EST
Should be fixed in glibc-2.3.6-3 in FC4 testing updates then.

Note You need to log in before you can comment on or make changes to this bug.