This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 17543 - Support of -hosts in autofs
Support of -hosts in autofs
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: autofs (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-15 13:24 EDT by Steve Dum
Modified: 2007-04-18 12:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-15 13:24:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Dum 2000-09-15 13:24:19 EDT
autofs now supports /net mounts, which on most other systems are designated
by a type of
-hosts in the automount tables.  It would be nice if
/etc/rc.d/init.d/autofs would deal with
a -hosts option rather than just stripping out all -* options.  The
following diffs to autofs-4.0.0pre7-23 autofs fix this
*** 101,106 ****
--- 101,109 ----
        do
              # These checks screen out duplicates and skip over
directories
              # where the map is '-'.
+           if [ "x$map" = "x-hosts" ]; then
+               map=/etc/auto.net
+           fi
            if [ ! -z "$dir" -a ! -z "$map" \
                        -a x`echo "$map" | cut -c1` != 'x-' \
                          -a "`echo "$knownmaps" | grep $dir/`" = "" ]
*****************
Comment 1 Nalin Dahyabhai 2000-09-15 14:16:47 EDT
We're backing off from autofs 4 for the release because it won't be ready in
time, so the issue is (sadly) moot.
Comment 2 Kenneth Heal 2003-11-16 11:42:05 EST
Am running RedHat 9 with kernel 2.4.20-20.9 and autofs 3.1.7-36 and 
finding that the Solaris-style /net -hosts mapping does not work.  
AutoFS 4 did not come with distrib and is not on RH RPMs site.  Does 
it fix this and does anyone know where I can get a stable RPM for an 
i686 box?

Thanks!

Note You need to log in before you can comment on or make changes to this bug.