Bug 175432 - MySQL running on only 1 CPU
MySQL running on only 1 CPU
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-10 06:34 EST by Stefan Neufeind
Modified: 2013-07-02 23:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-04 22:04:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Neufeind 2005-12-10 06:34:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
Installed mysql on a a dual-core, dual-processor-system running latest FC4 on x86_64.

Though on the previous system running mysql with 32-bit several processes showed up and were distributed across multiple processors, now there is only one mysql-processes e.g. showing up in top, and it's only using cpu-time from one cpu.

Could this be an issue with mysql not being built for SMP-systems or something?

400 mysql-connections connected, all executing queries. I see 400 threads running, but only one mysql-process, and that's only running on one and the same cpu all the time.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run mysql on FC4-system on x86_64 with multiple processors
2.
3.
  

Additional info:
Comment 1 Tom Lane 2005-12-10 11:36:20 EST
You'd probably have better luck filing this at www.mysql.com; I don't know their
code nearly well enough to guess what the issue might be.

In any case, not supplying the exact package version is a faux pas.  "Latest
FC4" is meaningless.
Comment 2 Stefan Neufeind 2005-12-10 12:15:29 EST
Sorry for that. The versions installed are:

mysql-4.1.15-1.FC4.1
mysql-server-4.1.15-1.FC4.1

I looked it up: The system on which mysql was running fine with multiple
proceessors was FC3. However, since there were no mysql 4.x-packages for FC3,
the packages from MySQL themselves were used.

Is there any compile-flag that might have been used when packaging the RPM to
disable the use of multiple processes/processors?
Comment 3 Tom Lane 2005-12-10 23:23:18 EST
Nope ... not intentionally, anyway ...

If you can give me a pointer to the exact SRPM for the MySQL version you were using on the previous 
system, I could compare flags to see if anything turns up.
Comment 4 Colin Charles 2005-12-11 04:22:56 EST
Stefan, you mention that in FC-3, you used packages from MySQL itself. Were thse mysql-4 packages you 
picked from www.mysql.com ? These were on a 32-bit system, as well?

And on FC-4, you're using mysql packages provided by Fedora, right? And these are on a x86_64 system?

As Tom has suggested, please provide the exact SRPM that you were using (if this was from mysql.com, 
we can probably get that online).
Comment 5 Stefan Neufeind 2005-12-11 05:52:46 EST
During nightly maintainence we switched to the RPMs directly from MySQL. Those
still run on one processor only. Maybe it has to do with MySQL building on
64-bit. I'll get back to this thread as soon as we hear back from MySQL.

Thread at MySQL-bugsystem:
http://bugs.mysql.com/bug.php?id=15661
Comment 6 Tom Lane 2006-01-04 22:04:03 EST
Closing as UPSTREAM, since this has been properly reported to upstream developers.
Comment 7 Stefan Neufeind 2006-02-16 14:14:04 EST
Just for your information: Seems it was no real issue. On the newer system the
kernel seems to load-balance across CPUs differently. While only lightly loaded
utilisation stays on one CPU, spreads as load rises.
Comment 8 Tom Lane 2006-02-16 14:26:59 EST
Great, I'll re-mark as NOTABUG then.  Many thanks for following up on it.

Note You need to log in before you can comment on or make changes to this bug.