Bug 1754393 - mgr/volumes: issuing `fs subvolume getpath` command hangs and ceph-mgr daemon hits 100% CPU utilization
Summary: mgr/volumes: issuing `fs subvolume getpath` command hangs and ceph-mgr daemon...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: CephFS
Version: 4.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 4.0
Assignee: Ram Raja
QA Contact: ymane
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-23 07:13 UTC by Ram Raja
Modified: 2020-01-31 12:47 UTC (History)
6 users (show)

Fixed In Version: ceph-14.2.4-4.el8cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:47:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 41903 0 None None None 2019-09-23 07:13:02 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:47:31 UTC

Description Ram Raja 2019-09-23 07:13:02 UTC
Description of problem:
After creating a FS subvolume, fetching its path hangs.

How reproducible: Always

Steps to Reproduce:
```
   $ ceph fs subvolume create vol00 subvol00
   $ ceph fs subvolume getpath vol00 subvol00
```
Actual results:
The second command just hangs and ceph-mgr daemon hits 100% CPU utilization

Expected results:
The `fs getpath` command should return the path of the FS subvolume and ceph-mgr shouldn't utilize 100% CPU.

Comment 7 errata-xmlrpc 2020-01-31 12:47:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.