Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
Version-Release number of selected component (if applicable):
Satellite 6.6
How reproducible:
Always
Steps to Reproduce:
1. Scap Ansible role is not imported into satellite
2. Try to update existing puppet policy
Actual results:
ActiveRecord::AssociationTypeMismatch
AnsibleRole(#66352280) expected, got nil which is an instance of NilClass(#9657900)
/opt/theforeman/tfm-ror52/root/usr/share/gems/gems/activerecord-5.2.1/lib/active_record/associations/association.rb:238:in `raise_on_type_mismatch!'
/opt/theforeman/tfm-ror52/root/usr/share/gems/gems/activerecord-5.2.1/lib/active_record/associations/has_many_through_association.rb:17:in `block in concat'
Expected results:
Unable to save
Required Ansible role theforeman.foreman_scap_client was not found, please ensure it is imported first
Additional info:
How did you update the policy? UI or API? I think it should be forbidden to change the policy deployment mode. Or was that a regular update of the policy (e.g. name)?
The ansible role is not imported to satellite
I have a puppet Policy already in satellite.
IF we want to create a new ansible policy, I get a validation error , to import the Ansible role. This is correct and Valid
But, If I want update the existing puppet role with ansible, I should get the same validation error, but instead on submit it breaks the page.
Update is done through UI
This issue is to track the validation error on update with there is no ansible role.
PFA,
Build: Satellite 6.7 snap7
Page doesn't break now and display a Validation error for user
Unable to save
Required Ansible role theforeman.foreman_scap_client was not found, please ensure it is imported first.
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHSA-2020:1454