Bug 1754515 - [downstream clone - 4.3.7] get_otopi_python always prefers Python3 even when site-packages are Python2 on RHEL 7.7
Summary: [downstream clone - 4.3.7] get_otopi_python always prefers Python3 even when ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: otopi
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ovirt-4.3.7
: 4.3.7
Assignee: Yedidyah Bar David
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On: 1751324
Blocks: 1762733 1762742
TreeView+ depends on / blocked
 
Reported: 2019-09-23 13:07 UTC by RHV bug bot
Modified: 2019-12-12 10:37 UTC (History)
13 users (show)

Fixed In Version: otopi-1.8.4-1.el7ev
Doc Type: Bug Fix
Doc Text:
Previously, with Red Hat Virtualization 4.3 on RHEL 7, if the system had Python 3 installed, otopi used Python 3. This caused relevant tools such as engine-setup and ovirt-host-deploy to fail. The current release fixes this issue: Now, even with Python 3 installed, otopi uses Python 2, enabling otopi-based tools such as engine-setup and ovirt-host-deploy to succeed. In the next minor version, 1.9, otopi should support Python 3 on RHEL 8 and Fedora.
Clone Of: 1751324
Environment:
Last Closed: 2019-12-12 10:37:23 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:4233 0 None None None 2019-12-12 10:37:46 UTC
oVirt gerrit 103342 0 'None' MERGED core: Use python 2 on EL7 2021-01-29 16:59:03 UTC
oVirt gerrit 103495 0 'None' MERGED core: Use python 2 on EL7 2021-01-29 16:59:47 UTC

Description RHV bug bot 2019-09-23 13:07:04 UTC
+++ This bug is an upstream to downstream clone. The original bug is: +++
+++   bug 1751324 +++
======================================================================

Description of problem:
As previously described with Bug 1688811, an python3 will cause Otopi to pick it first, but for all the system libraries only exist as Python2 code on CentOS 7

With Python3 being included in the standard, the argument cited for "wontfix" in the bug 1688811 may need to be revised.

Version-Release number of selected component (if applicable):
oVirt 4.3.5.2 otopi 1.8.3-1.el7

How reproducible:
, try to add it as a new host to oVirt,

Steps to Reproduce:
1. Install python3 on target host-to-add
2. try to add host to oVirt engine
3. /var/log/ovirt-engine/host-deploy/ovort-host-deploy<unique-id>.log will contain error messages that rpmUtils could not be imported.

Actual results:
Host installation fails quickly, needs to be removed immediately or there will be followup problems, because it cannot go into maintenance for proper removal

Expected results:
Host installed and usable

Additional info:
took more than three weeks to track down, very hard to find

(Originally by thomas)

Comment 1 RHV bug bot 2019-09-23 13:07:07 UTC
Sandro - do we want this in 4.3? I think so.

(Originally by didi)

Comment 6 Petr Matyáš 2019-10-31 15:28:40 UTC
Verified on otopi-common-1.8.4-1.el7ev.noarch

Comment 10 errata-xmlrpc 2019-12-12 10:37:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4233


Note You need to log in before you can comment on or make changes to this bug.