Bug 1754540 - build of opendkim for EPEL 8
Summary: build of opendkim for EPEL 8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: opendkim
Version: epel8
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Korbar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1765081 (view as bug list)
Depends On: 1754079
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-23 14:00 UTC by Breno
Modified: 2020-02-13 00:27 UTC (History)
31 users (show)

Fixed In Version: opendkim-2.11.0-0.9.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-13 00:27:00 UTC
Type: Bug


Attachments (Terms of Use)

Description Breno 2019-09-23 14:00:11 UTC
Hi,

I would like to ask a build of opendkim for EPEL 8.

Would you mind requesting the branches and build them?

It would be very nice if you could also include the --with-lua option.

Thank you very much.

- Breno

Comment 1 Breno 2019-10-02 13:14:16 UTC
FYI, adding the --with-lua option may require a patch in the source in order to fix lua_load and lua_dump.
it seems pretty straightforward, though.

Comment 2 robert.maerz 2019-10-19 20:53:03 UTC
I want to request opendkim to be build for EPEL8 as well, please.

Comment 3 sorje 2019-10-27 15:34:55 UTC
+1

Comment 4 Dimitris 2019-10-28 08:28:39 UTC
+1

Comment 5 Damien Dye 2019-10-28 10:08:22 UTC
+1 here too

Comment 6 Johan Kok 2019-11-09 07:46:07 UTC
*** Bug 1765081 has been marked as a duplicate of this bug. ***

Comment 7 Ben Warriner 2019-11-19 21:37:28 UTC
+1

Comment 8 Ivan Ivanov 2019-11-28 11:50:33 UTC
+1

Comment 9 GeorgeL 2019-12-09 02:34:37 UTC
are we waiting on other dependencies for opendkim on EPEL 8 ? like firebird and opendbx ?

rpmbuild -ba firebird.spec
error: Failed build dependencies:
        chrpath is needed by firebird-3.0.4.33054-4.el8.x86_64
        libedit-devel is needed by firebird-3.0.4.33054-4.el8.x86_64
        libicu-devel is needed by firebird-3.0.4.33054-4.el8.x86_64
        libstdc++-static is needed by firebird-3.0.4.33054-4.el8.x86_64
        libtommath-devel is needed by firebird-3.0.4.33054-4.el8.x86_64
        procmail is needed by firebird-3.0.4.33054-4.el8.x86_64

rpmbuild -ba opendbx.spec
error: Failed build dependencies:
        docbook2X is needed by opendbx-1.4.6-21.el8.x86_64
        doxygen is needed by opendbx-1.4.6-21.el8.x86_64
        firebird-devel is needed by opendbx-1.4.6-21.el8.x86_64
        freetds-devel is needed by opendbx-1.4.6-21.el8.x86_64
        libpq-devel is needed by opendbx-1.4.6-21.el8.x86_64
        mysql-devel is needed by opendbx-1.4.6-21.el8.x86_64

rpmbuild -ba opendkim.spec       
error: Failed build dependencies:
        libbsd is needed by opendkim-2.11.0-0.9.el8.x86_64
        libbsd-devel is needed by opendkim-2.11.0-0.9.el8.x86_64
        libdb-devel is needed by opendkim-2.11.0-0.9.el8.x86_64
        opendbx-devel is needed by opendkim-2.11.0-0.9.el8.x86_64
        sendmail-devel is needed by opendkim-2.11.0-0.9.el8.x86_64

Comment 10 Frédéric Nass 2019-12-09 07:44:49 UTC
Hi,

I believe we're missing opendbx and opendbx-devel. I installed opendbx and opendbx-devel from epel7 repository and could build opendkim 2.11.

1. Install these packages from RHEL8 repositories:

dnf install libdb-devel libmemcached-devel libtool openldap-devel sendmail-devel rpmdevtools make

2. Add epel7 repository to RHEL8:

vim /etc/yum.repos.d/epel7.repo

[epel7]
name=Extra Packages for Enterprise Linux 7 - x86_64
#baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=epel-7&arch=x86_64
failovermethod=priority
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7

[epel7-debuginfo]
name=Extra Packages for Enterprise Linux 7 - x86_64 - Debug
#baseurl=http://download.fedoraproject.org/pub/epel/7/$basearch/debug
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=epel-debug-7&arch=x86_64
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
gpgcheck=1

[epel7-source]
name=Extra Packages for Enterprise Linux 7 - x86_64 - Source
#baseurl=http://download.fedoraproject.org/pub/epel/7/SRPMS
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=epel-source-7&arch=x86_64
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
gpgcheck=1

3. Add the repository key

wget -O /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7 https://dl.fedoraproject.org/pub/epel/RPM-GPG-KEY-EPEL-7

4. Install opendbx and opendbx-devel

dnf install opendbx opendbx-devel --enablerepo=epel7

5. Get opendkim sources from epel7:

wget http://download-ib01.fedoraproject.org/pub/epel/7/SRPMS/Packages/o/opendkim-2.11.0-0.1.el7.src.rpm
rpm -ivh opendkim-2.11.0-0.1.el7.src.rpm

6. Configure rpmdev or whatever that does...

rpmdev-setuptree

7. Build opendkim from the sources:

rpmbuild -bb ~/rpmbuild/SPECS/opendkim.spec

This comes from my .zsh_history so I'm not sure to have all the steps here.

Regards,
Frederic.

Comment 11 GeorgeL 2019-12-09 15:17:46 UTC
Thanks Federic your instructions worked wonderfully. Hoping to eventually see EPEL 8 sporting opendkimm packages but for now this will have to make do. 

yum info opendkim-2.11.0-0.1.el8.x86_64
Last metadata expiration check: 0:22:14 ago on Tue 10 Dec 2019 12:49:01 AM AEST.
Installed Packages
Name         : opendkim
Version      : 2.11.0
Release      : 0.1.el8
Arch         : x86_64
Size         : 634 k
Source       : opendkim-2.11.0-0.1.el8.src.rpm
Repo         : @System
From repo    : @commandline
Summary      : A DomainKeys Identified Mail (DKIM) milter to sign and/or verify mail
URL          : http://opendkim.org/
License      : BSD and Sendmail
Description  : OpenDKIM allows signing and/or verification of email through an open source
             : library that implements the DKIM service, plus a milter-based filter
             : application that can plug in to any milter-aware MTA, including sendmail,
             : Postfix, or any other MTA that supports the milter protocol.

rpm -ql opendkim-2.11.0-0.1.el8.x86_64 | egrep 'bin|.conf'
/etc/opendkim.conf
/etc/sysconfig/opendkim
/etc/tmpfiles.d/opendkim.conf
/usr/sbin/opendkim
/usr/sbin/opendkim-default-keygen
/usr/sbin/opendkim-genkey
/usr/sbin/opendkim-genzone
/usr/sbin/opendkim-reportstats
/usr/sbin/opendkim-testkey
/usr/sbin/opendkim-testmsg
/usr/share/doc/opendkim/opendkim.conf.sample
/usr/share/doc/opendkim/opendkim.conf.simple
/usr/share/doc/opendkim/opendkim.conf.simple-verify
/usr/share/man/man5/opendkim.conf.5.gz

rpm -ql libopendkim-devel-2.11.0-0.1.el8.x86_64 | egrep '.so|.h$'
/usr/include/opendkim/dkim.h
/usr/lib64/libopendkim.so

Comment 12 pina 2019-12-15 10:51:50 UTC
I also want to request opendkim to be build for EPEL8 as well.

Comment 13 Roger T 2019-12-24 00:25:05 UTC
+1

Comment 14 Trevor Hemsley 2019-12-28 13:41:10 UTC
Just to point out that installing EPEL 7 on RHEL/CentOS 8 is the wrong thing to do. There should be no ".el7." packages installed on a RHEL/CentOS 8 system at all.

You should be downloading those missing package SRPMs and rebuilding those for el8 and adding them to an intermediate repo to be used for the opendkim build. 

The EPEL 7 opendbx SRPM does not build cleanly on CentOS 8 (missing sqlite2 packages) but the Fedora 30 one does, so that is the one that should be used. Downloading opendbx-1.4.6-20.fc30.src.rpm and feeding that into `mock --rebuild opendbx-1.4.6-20.fc30.src.rpm` generates various packages and adding those to the local yum repo used by mock lets me build opendkim-2.11.0-0.1.el8.x86_64.rpm cleanly and correctly for el8. It also works for the latest Fedora 30 SRPM opendkim-2.11.0-0.8.fc30.src.rpm which is probably a better thing to use rather than the EPEL 7 version.

Comment 15 kazakevichilya 2020-01-03 15:07:47 UTC
+1 for this issue. How can I run my MTA without of dkim?

Comment 16 Joe Pitt 2020-01-05 21:53:09 UTC
+1

Not currently possible to build a sane mail server on 8 without Postgrey, OpenDKIM and OpenDMARC

Comment 17 Breno 2020-01-08 22:19:48 UTC
Hi,

I hope I can help, I forked both opendkim[1] and opendbx[2] in src.fedoraproject.org and built them.
I performed some tests here, especially using the lua option, and seems to be working correctly.

They can be tested with the copr[3] mirror I've set.

I hope it helps somehow.

As I am in the packager group, feel free to add me as co-maintainer, if you feel like so.

Please let me know if you need anything.

Ps: I add a note in the opendbx ticket as well.

1 - https://src.fedoraproject.org/fork/brandfbb/rpms/opendkim/c/5025543cf6c373ff1159df492d4586d0338b7e20?branch=epel8
2 - https://src.fedoraproject.org/fork/brandfbb/rpms/opendbx/c/6ea303c262b20132f59ef8cae3c8140a1d8f3687?branch=epel8
3 - https://copr.fedorainfracloud.org/coprs/brandfbb/opendkim-on-EPEL-8/

- Breno

Comment 18 Denis 2020-01-10 18:10:35 UTC
+1
Very lacking OpenDKIM, OpenDMARC

Comment 19 Fedora Update System 2020-01-15 01:08:43 UTC
libspf2-1.2.10-24.20150405gitd57d79fd.el8, opendbx-1.4.6-21.el8, opendkim-2.11.0-0.9.el8, opendmarc-1.3.2-1.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-e8e71df342

Comment 20 Breno 2020-01-15 14:30:32 UTC
Dear maintainer, i think i asked it before, would it be possible to build it with the --with-lua option?

Comment 21 Vasiliy Glazov 2020-01-15 17:28:20 UTC
I am still not maintainer. I just built it for epel8.
Next build I will try with lua.

Comment 22 Breno 2020-01-15 18:14:32 UTC
Hi Vasiliy,

Sure, thanks for that.
Feel free to add me as co-maitainer if you feel like so or if you need more hands.

Thanks

- B

Comment 23 Fedora Admin XMLRPC Client 2020-02-06 04:14:20 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 24 jpchap 2020-02-11 08:21:57 UTC
+1

OpenDmarc and OpenDkim are missing to update any public Mta in CentOS 8.

Thank for all

Comment 25 Dimitris 2020-02-12 14:26:42 UTC
The packages have been frozen for the past 19 days or so, and nobody has pushed them to stable:

https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-e8e71df342

Comment 26 Fedora Update System 2020-02-13 00:27:00 UTC
libspf2-1.2.10-24.20150405gitd57d79fd.el8, opendbx-1.4.6-21.el8, opendkim-2.11.0-0.9.el8, opendmarc-1.3.2-1.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.