Bug 1754686 - DHCP mode failed when configuring it in multus CNI IPAM
Summary: DHCP mode failed when configuring it in multus CNI IPAM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.2.z
Assignee: Tomofumi Hayashi
QA Contact: Weibin Liang
URL:
Whiteboard:
Depends On: 1754682
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-23 22:02 UTC by Ben Bennett
Modified: 2019-10-30 04:45 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1754682
Environment:
Last Closed: 2019-10-30 04:44:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 331 'None' closed Bug 1754686: The DHCP daemon should mount the directory for the socketfile (backport 4.2) 2020-06-08 17:37:34 UTC
Red Hat Product Errata RHBA-2019:3151 None None None 2019-10-30 04:45:04 UTC

Description Ben Bennett 2019-09-23 22:02:22 UTC
+++ This bug was initially created as a clone of Bug #1754682 +++

Description of problem:
Can not create pod when configuring DHCP mode in multus macvlan type

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-09-22-222738

How reproducible:
Always

Steps to Reproduce:
1. Install and enable external DHCP server
2. Create project and net-attach-def
oc new-project test1
oc edit networks.operator.openshift.io -o yaml
spec:
  additionalNetworks:
  - name: macvlan-ipam-static
      namespace: test1
      simpleMacvlanConfig:
      ipamConfig:
        type: dhcp
      master: ens5
      mode: bridge
    type: SimpleMacvlan
3. Create a pod
cat pod1.yaml 
apiVersion: v1
kind: Pod
metadata:
  name: pod1
  annotations:
    k8s.v1.cni.cncf.io/networks: macvlan-ipam-static
spec:
  containers:
  - name: pod1
    command: ["/bin/bash", "-c", "sleep 2000000000000"]
    image: dougbtv/centos-network

oc create -f pod1.yaml

Actual results:
[root@dhcp-41-193 FILE]# oc get pods
NAME   READY   STATUS              RESTARTS   AGE
pod1   0/1     ContainerCreating   0          16m

[root@dhcp-41-193 FILE]# oc describe pod pod1
Events:
  Type     Reason                  Age                 From                     Message
  ----     ------                  ----                ----                     -------
  Normal   Scheduled               16m                 default-scheduler        Successfully assigned test1/pod1 to ip-10-0-61-249
  Warning  FailedCreatePodSandBox  16m                 kubelet, ip-10-0-61-249  Failed create pod sandbox: rpc error: code = Unknown desc = failed to create pod network sandbox k8s_pod1_test1_705aacf6-de48-11e9-8f2b-02a758168282_0(94adcd6f27f216f1daee848abbb4874efa149549bb5d5a658911c5994642ead5): Multus: Err adding pod to network "macvlan-ipam-static": Multus: error in invoke Delegate add - "macvlan": error dialing DHCP daemon: dial unix /run/cni/dhcp.sock: connect: no such file or directory


Expected results:
Pod is running and secondary interface get ip address

Additional info:

--- Additional comment from Anurag saxena on 2019-09-23 17:53:26 EDT ---

This is seen on both vSphere and Baremetal impacting all dhcp IPAM usecases.

Comment 1 zhaozhanqi 2019-09-24 09:35:20 UTC
hi, Ben Bennett
 I saw the Target Release is '4.2.z' not '4.2'. do you mean it will not be fixed before 4.2 release, thanks.

Comment 3 Weibin Liang 2019-10-22 19:48:42 UTC
Verified in 4.2.0-0.ci-2019-10-22-035304.

[root@dhcp-41-193 FILE]# oc get pod pod-bridge-dhcp -o wide
NAME              READY   STATUS    RESTARTS   AGE   IP            NODE                                         NOMINATED NODE   READINESS GATES
pod-bridge-dhcp   1/1     Running   0          67s   10.131.0.16   ip-10-0-139-154.us-east-2.compute.internal   <none>           <none>
[root@dhcp-41-193 FILE]# 
[root@dhcp-41-193 FILE]# oc get net-attach-def
NAME               AGE
bridge-ipam-dhcp   103s
[root@dhcp-41-193 FILE]#

Comment 5 errata-xmlrpc 2019-10-30 04:44:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3151


Note You need to log in before you can comment on or make changes to this bug.