Bug 1754867 - gnome-shell crashes when pressing Ctrl+Super in a GTK application
Summary: gnome-shell crashes when pressing Ctrl+Super in a GTK application
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F31FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2019-09-24 09:20 UTC by Jonathan Haas
Modified: 2019-09-30 00:01 UTC (History)
11 users (show)

Fixed In Version: mutter-3.34.0-5.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-30 00:01:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME/mutter/issues/823 None None None 2019-09-24 09:20:56 UTC

Description Jonathan Haas 2019-09-24 09:20:57 UTC
Description of problem:
gnome-shell crashes when pressing Ctrl+Super in a GTK application

Version-Release number of selected component (if applicable):
mutter-3.34.0-3.fc31.x86_64

How reproducible: Always


Steps to Reproduce:

* Start a GNOME Wayland session
* Open a GTK application (tested with GNOME Terminal, Tilix, Dino, Thunderbird)
* Click on any text input field in the application to focus it
Press Ctrl+Super simultaneously

What happens:

* gnome-shell crashes

Tested with current mutter and gnome-shell releases (3.34.0) in Fedora 31 as well as their current master branches. Can't reproduce with Qt applications (neither native Wayland nor XWayland ones). Doesn't always trigger, try clicking into the text field and pressing the key combination a few times.

Expected results:

No crash

Comment 1 Jonathan Haas 2019-09-24 09:29:28 UTC
Proposing as a blocker, either under the data loss criterion or under default application functionality.

Note that there are a couple other major mutter issues related to keyboard input (that may or may not be related to this bug) and that is somewhat worrying:

https://gitlab.gnome.org/GNOME/mutter/issues/819
https://gitlab.gnome.org/GNOME/mutter/issues/820
https://gitlab.gnome.org/GNOME/mutter/issues/822

Comment 2 Adam Williamson 2019-09-24 15:01:45 UTC
Thanks for catching this. I think I'd be a weak +1 under the data loss criterion, as this is a pretty easy pair of keys to hit by mistake and we know that Shell crashing certainly can lead to data loss.

Comment 3 Michael Catanzaro 2019-09-25 20:52:06 UTC
I'm able to reproduce after 5-10 attempts at replication.

Unfortunately, all gnome-shell crashes are effectively impossible to debug right now. We need to solve bug #1748145 first, or we have no chance here.

Comment 4 Jonathan Haas 2019-09-26 07:21:39 UTC
There is already a patch at https://gitlab.gnome.org/GNOME/mutter/issues/823

Comment 5 Kamil Páral 2019-09-26 11:19:00 UTC
I've reproduced this trivially, my colleague as well. Certain +1 blocker from me.

Comment 6 František Zatloukal 2019-09-27 07:31:54 UTC
+1 blocker also from me.

Comment 7 Fedora Update System 2019-09-28 17:14:17 UTC
FEDORA-2019-94130905d5 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-94130905d5

Comment 8 Fedora Update System 2019-09-29 01:11:38 UTC
mutter-3.34.0-5.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-94130905d5

Comment 9 František Zatloukal 2019-09-29 20:57:08 UTC
mutter-3.34.0-5.fc31 fixes the issue.

Comment 10 Fedora Update System 2019-09-30 00:01:45 UTC
mutter-3.34.0-5.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.