This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 175488 - new selinux policy prevent sol from running
new selinux policy prevent sol from running
Status: CLOSED DUPLICATE of bug 175487
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-11 15:01 EST by Jason
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-12 09:57:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason 2005-12-11 15:01:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051129 Fedora/1.5-1 Firefox/1.5

Description of problem:
The new selinux policy prevents sol from running.  When I run sol I get the following error:
sol: error while loading shared libraries: libqthreads.so.12: cannot enable executable stack as shared object requires: Permission denied

I get the following in /var/log/audit/audit.log
type=AVC msg=audit(1134331204.241:168): avc:  denied  { execmem } for  pid=5005 comm="sol" scontext=root:system_r:unconfined_t:s0-s0:c0.c255 tcontext=root:system_r:unconfined_t:s0-s0:c0.c255 tclass=process
type=SYSCALL msg=audit(1134331204.241:168): arch=40000003 syscall=125 success=no exit=-13 a0=bf8fa000 a1=1000 a2=1000007 a3=b7fea7c8 items=0 pid=5005 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 comm="sol" exe="/usr/bin/sol"

See for details:
http://people.redhat.com/drepper/selinux-mem.html

I am running selinux-policy-targeted-2.1.2-1 in enforcing mode.

Version-Release number of selected component (if applicable):
gnome-games-2.13.2-1

How reproducible:
Always

Steps to Reproduce:
1.  install new selinux policy
2.  run sol
3.
  

Actual Results:  sol does not run

Expected Results:  sol and freecell should run

Additional info:
Comment 1 Jason 2005-12-12 09:57:13 EST

*** This bug has been marked as a duplicate of 175487 ***

Note You need to log in before you can comment on or make changes to this bug.