Bug 1754904 - python-nitrate: Remove (sub)packages from Fedora 32+: python2-nitrate (retire the package)
Summary: python-nitrate: Remove (sub)packages from Fedora 32+: python2-nitrate (retire...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-nitrate
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1738106 (view as bug list)
Depends On:
Blocks: PY2REMOVAL F31_PY2REMOVAL 1745466
TreeView+ depends on / blocked
 
Reported: 2019-09-24 10:49 UTC by Miro Hrončok
Modified: 2019-10-01 07:43 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-01 07:43:15 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2019-09-24 10:49:52 UTC
In line with the Mass Python 2 Package Removal [0], the following (sub)packages of python-nitrate were marked for removal:

 * python2-nitrate

According to our query, those (sub)packages only provide a Python 2 importable module. If this is not true, please tell us why, so we can fix our query.

Please remove them from your package in Rawhide (Fedora 32).

Please don't remove packages from Fedora 31, it is past Beta Freeze.
Please don't do this for Fedora 30/29 either, removing packages from a released Fedora branch is forbidden.

As said in the change document, if there is no objection in a week, we will remove the package(s) as soon as we get to it. This change might not match your packaging style, so we'd prefer if you did the change. If you need more time, please let us know here.

If you do the change yourself, it would help us a lot by reducing the amount of packages we need to mass change.

We hope this doesn't come to you as a surprise. If you want to know our motivation for this, please read the change document [0].

[0] https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal

Comment 1 Miro Hrončok 2019-09-24 10:51:52 UTC
From the description:

	
python-nitrate is a Python interface to the Nitrate test case
management system. The package consists of a high-level Python
module (provides natural object interface), a low-level driver
(allows to directly access Nitrate's XMLRPC API) and a command
line interpreter (useful for fast debugging and experimenting).


There ia command line app, but it is only useful for fast debugging and experimenting, the primary reason for thsi package is a Python 2 module that nothing depends on.

Comment 2 Miro Hrončok 2019-09-24 10:52:04 UTC
*** Bug 1738106 has been marked as a duplicate of this bug. ***

Comment 3 Miro Hrončok 2019-10-01 07:43:15 UTC
Retired.


Note You need to log in before you can comment on or make changes to this bug.