Bug 175497 - libsysfs located in /usr/lib makes multipath fail on boot
libsysfs located in /usr/lib makes multipath fail on boot
Status: CLOSED INSUFFICIENT_DATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: sysfsutils (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-11 17:53 EST by Victoriano Giralt
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-05 16:44:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Victoriano Giralt 2005-12-11 17:53:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

Description of problem:
Multipath userland tool depends on libsysfs. As this library is located in /usr/lib, and /usr not being mounted in early statup phases, multipath cannot start and prepare multipath devices appropriatelly.

Version-Release number of selected component (if applicable):
sysfsutils-1.2.0-1

How reproducible:
Always

Steps to Reproduce:
1.Install device-mapper-multipath
2.Reboot the system
3.multipaht fails
  

Expected Results:  multipath shpuld have worked

Additional info:

Problem is solved with following commands:

# cp /usr/lib/libsysfs.so.1.0.2 .
# ln -s libsysfs.so.1.0.2 libsysfs.so.1
# ln -s libsysfs.so.1.0.2 libsysfs.so
# ldconfig
Comment 3 Neil Horman 2005-12-12 10:50:35 EST
how are you using multipath during bootup?

Are you just trying to multipath your rootfs?
If so, how did you build your initrd?

Are you using any additional scripts during startup with multipath?
If so, you should use /sbin/multipath.static instead.
Comment 6 Jarod Wilson 2007-02-05 16:44:18 EST
Closing, based on lack of response to the bug for over a year now.

Note You need to log in before you can comment on or make changes to this bug.