Bug 1755035 - [RFE] EPEL8 branch of python-paramiko
Summary: [RFE] EPEL8 branch of python-paramiko
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-paramiko
Version: epel8
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1755117
Blocks: 1744975
TreeView+ depends on / blocked
 
Reported: 2019-09-24 15:10 UTC by Pat Riehecky
Modified: 2019-10-27 00:12 UTC (History)
10 users (show)

Fixed In Version: python-paramiko-2.4.3-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-27 00:12:26 UTC
Type: Bug


Attachments (Terms of Use)

Description Pat Riehecky 2019-09-24 15:10:53 UTC
Description of problem:

Can pyhton-paramiko be branched for EPEL8?  This is required for ansible.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Orion Poplawski 2019-09-24 16:23:52 UTC
I'll just note that it is interesting that ansible from the ansible-2.8-for-rhel-8-x86_64-rpms repository does not require python-paramiko.  ansible can certainly use it, but it is not strictly required.

Comment 2 Paul Howarth 2019-09-24 18:30:41 UTC
I can do this but:

1. It will be paramiko 2.4.3 because 2.5.0 and above require python-cryptography 2.5 or later and EL-8 has python-cryptography 2.3.
2. It will be Python 3 only; even if I wanted to build for Python 2 (which I don't), the necessary dependencies aren't available.

Will that be OK for you?

Comment 3 Pat Riehecky 2019-09-24 18:37:13 UTC
All of that seems fine to me.

Comment 5 Paul Howarth 2019-09-24 19:36:37 UTC
Well it looks like python-pynacl isn't available, though it was in the EL8 beta.

I've requested a branch of that for EPEL now.

Comment 6 Fedora Update System 2019-10-11 15:26:08 UTC
FEDORA-EPEL-2019-88c40ed38a has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-88c40ed38a

Comment 7 Fedora Update System 2019-10-11 23:27:44 UTC
python-paramiko-2.4.3-1.el8, python-pynacl-1.3.0-5.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-88c40ed38a

Comment 8 Fedora Update System 2019-10-27 00:12:26 UTC
python-paramiko-2.4.3-1.el8, python-pynacl-1.3.0-5.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.