Bug 175507 - cannot exit the X server
cannot exit the X server
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-11 20:29 EST by Amadeus W. M.
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-18 17:58:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amadeus W. M. 2005-12-11 20:29:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Can't exit the X server afer a fresh installation of FC4 on a Dell Inspiron 2650, immediately updated to the latest packages. 

Happens both with the nv and the nvidia drivers and with 

kernel-2.6.11-1.1369_FC4
kernel-2.6.14-1.1644_FC4


Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-37.FC4.49.2

How reproducible:
Always

Steps to Reproduce:
1.boot to level 3
2.startx
3.logout/reboot

Actual Results:  With the nvidia driver, the screen turns black and computer freezes. Can't login remotely.

With the nv driver, I get the prompt, but the screen is corrupted. However it is possible to restart X. 

Expected Results:  should have gotten a prompt and a clean console. 

Additional info:

Currently running

kernel-2.6.14-1.1644_FC4
xorg-x11-6.8.2-37.FC4.49.2

The graphics card is Nvidia GeForce2 Go, so I installed also

kernel-module-nvidia-2.6.14-1.1644_FC4-1.0.8174-0.lvn.1.4
nvidia-glx-1.0.8174-0.lvn.1.4

Using the nvidia driver, at resolution 1024x768 the screen turns black and the computer freezes when I exit X. Changing the driver to nv, I can exit X, but the consoled is corrupted. It looks like there's "debris" reminiscent of booting, and the screen wraps around. With either driver the problem happens both with the latest kernel (2.6.14-1.1644_FC4) as well with the original kernel (2.6.11-1.1369_FC4). 

After some trial-and-error, I commented out Load "glx" in xorg.conf, and the problems disappears (both for the nvidia and the nv driver, either kernel).

So I reckon this must be glx bug. 

Unfortunately the original FC4 X server is gone, so I can't tell wether or not this problem occurs with that one as well.
Comment 1 Mike A. Harris 2006-03-08 04:56:29 EST
Completely uninstall the nvidia proprietary driver, and do a full reboot.

Update to the latest FC packages that have been released, and try to
reproduce with the "nv" driver.  If it is still reproduceable, update
the report with your xorg.conf and X server log as individual uncompressed
file attachments for review.

TIA
Comment 2 Mike A. Harris 2006-05-18 17:58:02 EDT
For users who are experiencing problems installing,
configuring, or using the unsupported 3rd party proprietary
"nvidia" video driver, Nvidia provides indirect customer
support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and
passes them on to Nvidia engineers for investigation.  Once
they've isolated a particular problem, it is often fixed in
a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums,
others who may have experienced the particular problem may
be able to assist.  If there is a real bug occuring, Nvidia
will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system
releases that they officially support.

While Red Hat does not support the proprietary nvidia driver,
users requiring technical support may also find the various
X.Org, XFree86, and Red Hat mailing lists helpful in finding
assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Setting status to "CANTFIX" (unsupported).

Note You need to log in before you can comment on or make changes to this bug.