Bug 175522 - (orgchartperldap) Org Chart tool doesn't work
Org Chart tool doesn't work
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: UI - Org Chart (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
: 175801 (view as bug list)
Depends On:
Blocks: 152373 183369 240316
  Show dependency treegraph
 
Reported: 2005-12-12 04:27 EST by Matteo Catanese
Modified: 2015-12-07 12:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 12:09:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
put this in /etc/ld.so.conf.d, run ldconfig and it will (apparently) solve the problem (71 bytes, text/plain)
2005-12-12 04:27 EST, Matteo Catanese
no flags Details

  None (edit)
Description Matteo Catanese 2005-12-12 04:27:36 EST
Description of problem:

Fedora core 4 with all latest updates

Directory Server default install

Cant print org chart of a selected user

Version-Release number of selected component (if applicable):
1.0 and 1.0.1

How reproducible:

Print a chart from the web interface

Steps to Reproduce:
1. http://server.example.com:port/clients/orgchart/html/index.html
2. Search for: user
3. Click on GO
  
Actual results:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [no address given] and inform them of the time the error 
occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

Apache/2.0 Server at fedoratest.example.com Port 10100


Expected results:

the graph :-)

Additional info:

Seems it can't find some libraries
[Mon Dec 12 10:21:13 2005] [error] [client 192.168.17.62] Can't load '/opt/fedora-ds/lib/perl/arch/
auto/Mozilla/LDAP/API
/API.so' for module Mozilla::LDAP::API: libldap50.so: cannot open shared object file: No such file or 
directory at /usr/
lib/perl5/5.8.6/i386-linux-thread-multi/DynaLoader.pm line 230., referer: http://
fedoratest.example.com:10100/clients/or
gchart/html/topframe.html
Comment 1 Matteo Catanese 2005-12-12 04:27:36 EST
Created attachment 122124 [details]
put this in /etc/ld.so.conf.d, run ldconfig and it will (apparently) solve the problem
Comment 2 Rich Megginson 2005-12-12 10:42:29 EST
This is the second time someone has run into this problem.  Are you a perl
hacker?  If so, can you take a look at the BEGIN section in
clients/orgchart/bin/org?  This is where we attempt to set the LD_LIBRARY_PATH
env. var. so that it can find libldap50.so when it loads the perldap modules. 
For some reason, on some systems, you can set LD_LIBRARY_PATH in the BEGIN
section and it works, and on other systems it doesn't.

grazie
Comment 3 Matteo Catanese 2005-12-13 04:07:51 EST
Unfortunately im not a perl hacker.

But i saw org script and:

$ENV{LD_LIBRARY_PATH} .= "$sroot/shared/lib";

i think this is not enough

you should also put $sroot/client/lib

Ciao

Comment 4 Rich Megginson 2005-12-15 17:41:53 EST
*** Bug 175801 has been marked as a duplicate of this bug. ***
Comment 5 Rich Megginson 2006-02-08 13:58:53 EST
The work around is to put
SetEnv LD_LIBRARY_PATH /opt/fedora-ds/shared/lib
near the top of admin-serv/config/admserv.conf
then restart-admin.

We are working on a better solution for an upcoming release.
Comment 6 George 2006-02-18 07:45:13 EST
Use the latest perl from /usr/bin/.
bash-3.00$ ls -al /usr/bin/perl*
-rwxr-xr-x  2 root root 20736 Dec 20 17:17 /usr/bin/perl
-rwxr-xr-x  2 root root 20736 Dec 20 17:17 /usr/bin/perl5.8.5

Now edit these two files:
 /opt/fedora-ds/clients/orgchart/bin/myorg
/opt/fedora-ds/clients/orgchart/bin/org
Comment 7 George 2006-02-18 07:47:11 EST
I didn't get to finish(In reply to comment #6)
> Use the latest perl from /usr/bin/.
> bash-3.00$ ls -al /usr/bin/perl*
> -rwxr-xr-x  2 root root 20736 Dec 20 17:17 /usr/bin/perl
> -rwxr-xr-x  2 root root 20736 Dec 20 17:17 /usr/bin/perl5.8.5
> 
> Now edit these two files:
>  /opt/fedora-ds/clients/orgchart/bin/myorg
> /opt/fedora-ds/clients/orgchart/bin/org
 and point to the latest perl.
For ex:
#!/usr/bin/env /usr/bin/perl5.8.5

This works for me.


Comment 8 Michael Gregg 2007-11-20 13:39:41 EST
Works aginst:
1195583609 redhat-ds-base-8.0.0-11.el5dsrv Tue Nov 20 2007 
1195583611 redhat-ds-admin-8.0.0-1.15.el5dsrv Tue Nov 20 2007 
1195583613 redhat-ds-console-8.0.0-8.el5dsrv Tue Nov 20 2007 
1195583614 redhat-admin-console-8.0.0-9.el5dsrv Tue Nov 20 2007 
Comment 9 Michael Gregg 2007-11-20 13:48:26 EST
To clarify, the org chart isn't included in DS8.0

Though the URL doesn't cause a internal server error.

Note You need to log in before you can comment on or make changes to this bug.