Bug 1755242 - node:node_memory_bytes_available:sum recording rule is not available
Summary: node:node_memory_bytes_available:sum recording rule is not available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.2.z
Assignee: Sergiusz Urbaniak
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On: 1755240
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-25 07:23 UTC by Sergiusz Urbaniak
Modified: 2019-10-30 04:45 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1755240
Environment:
Last Closed: 2019-10-30 04:44:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 491 0 None None None 2019-10-16 09:50:09 UTC
Red Hat Product Errata RHBA-2019:3151 0 None None None 2019-10-30 04:45:04 UTC

Description Sergiusz Urbaniak 2019-09-25 07:23:31 UTC
+++ This bug was initially created as a clone of Bug #1755240 +++

Description of problem:

Clusters don't report memory usage via telemetry.

How reproducible:

https://infogw-cache.api.openshift.com/graph?g0.range_input=1h&g0.expr=count(count%20by%20(_id)(cluster%3Acpu_usage_cores%3Asum))&g0.tab=1&g1.range_input=1h&g1.expr=count(count%20by%20(_id)(cluster%3Amemory_usage_bytes%3Asum))&g1.tab=1

Slack discussion: https://coreos.slack.com/archives/CEG5ZJQ1G/p1569333490049400

Expected results:

Memory metrics are being reported.

Additional info:

https://github.com/openshift/cluster-monitoring-operator/pull/456 replaced the deprecated kube-prometheus node mixins with node mixins from node exporter.

The latter does not include the `node:node_memory_bytes_total:sum`/`node:node_memory_bytes_available:sum` recording rule, it has to be replaced with `node_memory_MemTotal_bytes{job="node-exporter"}`/` node_memory_MemAvailable_bytes{job="node-exporter"}`.

Comment 7 errata-xmlrpc 2019-10-30 04:44:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3151


Note You need to log in before you can comment on or make changes to this bug.