Bug 175532 - Themed Mouse Cursors Not Shown
Themed Mouse Cursors Not Shown
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libXcursor (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-12 08:51 EST by Thomas J. Baker
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-13 18:21:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2005-12-12 08:51:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051202 Fedora/1.5-1.tjb Firefox/1.5

Description of problem:
After the modular X rawhide update, the themed mouse cursors were no longer shown. I then did a clean install of fc5t1 and the problem remained. The system is an Dell Inspiron 7500 running up to date fc5t1+rawhide. The graphics card is this:

01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility P/M AGP 2x (rev 64) (prog-if 00 [VGA])



Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.5.7-1

How reproducible:
Always

Steps to Reproduce:
1. install modular X
2. run X
3.
  

Actual Results:  no themed cursors

Additional info:
Comment 1 Sammy 2005-12-12 09:59:32 EST
I had the same problem and fixed it by creating the directory:

                  /usr/share/icons/default

and putting in a file called "index.theme" containing the lines:

[Icon Theme]
Inherits=reddot

where reddot is the directory containing my cursor theme. Also, under the
icon theme I am using under KDE there is a subdirectory called cursors. I
put the same cursors in there too. This worked for me.

Comment 2 Thomas J. Baker 2005-12-12 10:30:49 EST
I probably should add that this is under Gnome with any of the gnome cursor
themes. I have other fc5t1 installations where mouse cursor themes are working
fine so that's why I thought it was related to the X driver. (Another system is
working fine with the 'nv' driver.)
Comment 3 Sammy 2005-12-12 15:58:44 EST
Well, this seems to be a deeper issue. If you install a i386 applications like
firefox on a x86_64 system (like FC5test1) than the chosen cursors are not
working for the application and it is defaulting to the ugly X11 cursors.

If you install x86_64 version of firefox cursor theme is working fine! But now
none of the plugins work, which is why I am using the i386 firefox. Is there a
simple solution to this?
Comment 4 Sammy 2005-12-12 20:26:43 EST
I find that gtk cursor themes are not working on x86_64 systems.
I am going to file another bug under gtk2. 
Comment 5 Thomas J. Baker 2005-12-13 09:31:52 EST
Given the state of rawhide at the moment, it's tough to tell where the bug in
this bug report lies. I'll report back when mouse cursors are working on my
nvidia based test system to verify that they are still broken on my ATI based
system.
Comment 6 Mike A. Harris 2005-12-13 18:21:49 EST
The problem is caused due to X.Org modular not supplying an index.theme file
by default, nor having an option to set it at build time.  This is an oversight
in the conversion from Imake to autotools, and will probably be fixed in a
future Xorg test release.  In the mean time, I have hacked up a workaround in
the spec file that sets the default to BlueCurve.

Fixed in libXcursor-1.1.5.1-1
Comment 7 Bart Vanbrabant 2005-12-15 06:18:25 EST
I've installed libXcursor-1.1.5.1-1 and the problem still remains. It's isn't a
clean install though, it's rawhide since FC4test1. But I don't think that could
be the reason.
Comment 8 Sammy 2005-12-15 10:52:10 EST
At least my problem (and possibly the original reporter) is the default 
cursor not showing up for i386 applications on x86_64. I have installed 
libXcursors i386 and x86_64 versions on my x86_64 system. 64 bit applications 
show the default cursor fine but i386 applications do not (both gtk2 and X11 
applications). To see this just start any i386 application on x86_64 system 
which has some default cursor defined OR copy a i386 xterm binary from another 
system and use that. 

Note You need to log in before you can comment on or make changes to this bug.