Bug 175534 - FC luns not visable off Qlogic controller
FC luns not visable off Qlogic controller
Status: CLOSED DUPLICATE of bug 174427
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-12 09:19 EST by John Shakshober
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-12 10:45:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Shakshober 2005-12-12 09:19:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Red Hat/1.7.10-1.4.1

Description of problem:

Testing FC performance on 2 system w/ qlogic luns
on both perf3.lab x86_64 (amd64) and bigbaddell2.lab x64_64 (em64t)

Luns which are visable to RHEL4 GA, U1 and U2 are no longer visible in U3.
on Qlogic   qla2xxx 

Same beta kernel ran fine with Emulex driver on x86_64 (em64t) perf4.lab
 

Version-Release number of selected component (if applicable):
 2.6.9-24.ELsmp

How reproducible:
Always

Steps to Reproduce:
1. install RHEL4 U3
2. attempt to mount or 
3.
  

Actual Results:  lsmod output

scsi_mod              140561  9 qla2xxx,scsi_transport_fc,libata,megaraid_mbox,mptsas,mptspi,mptfc,mptscsi,sd_mod
[root@perf3 ~]# uname -a
Linux perf3.lab.boston.redhat.com 2.6.9-24.ELsmp #1 SMP Wed Nov 30 18:23:47 EST 2005 x86_64 x86_64 x86_64 GNU/Linux


[root@perf3 ~]# fdisk /dev/sdh1
dmesg
Buffer I/O error on device sdf1, logical block 0
SCSI error : <7 0 3 1> return code = 0x20000
end_request: I/O error, dev sdf, sector 64
Buffer I/O error on device sdf1, logical block 1
SCSI error : <7 0 3 1> return code = 0x20000
end_request: I/O error, dev sdf, sector 65
Buffer I/O error on device sdf1, logical block 2
SCSI error : <7 0 3 1> return code = 0x20000
end_request: I/O error, dev sdf, sector 66

(repeated until logical block 128)



Expected Results:  
Should have seen the devices and fdisk, mkfs or mount should all work.

Additional info:


Systems are available on perf3.lab.boston.redhat.com  (amd64)
or bigbaddell2.lab.boston.redhat.com (em64T)
Comment 1 Tom Coughlan 2005-12-12 10:45:15 EST
This looks like a dup of 174427. Please try kernel -24.1. 

Re-open this is if the problem persists. Provide all of the Qlogic related
/var/log/messages.

*** This bug has been marked as a duplicate of 174427 ***

Note You need to log in before you can comment on or make changes to this bug.