Bug 1755406 - teamd: deactivation of slave connection with team-port set does not change teamd config
Summary: teamd: deactivation of slave connection with team-port set does not change te...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-25 12:48 UTC by Filip Pokryvka
Modified: 2020-04-28 16:54 UTC (History)
9 users (show)

Fixed In Version: NetworkManager-1.22.0-0.2.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:53:06 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1847 0 None None None 2020-04-28 16:53:59 UTC

Description Filip Pokryvka 2019-09-25 12:48:38 UTC
Description of problem:
Deactivation of slave connection (having team-port.config set), does not propagate to teamd, it is still visible with `teamdctl <dev> config dump`.

Version-Release number of selected component (if applicable):
NetworkManager-1.20.0-3.el8.x86_64
NetworkManager-team-1.20.0-3.el8.x86_64
libteam-1.28-4.el8.x86_64
teamd-1.28-4.el8.x86_64

How reproducible:
always

Steps to Reproduce:
1. nmcli con add type team ifname nm-team con-name team0 team.runner activebackup ip4 172.20.1.3/24
2. nmcli con add type ethernet ifname eth5 master nm-team con-name team0.0 team-port.prio -10 team-port.sticky true
3. nmcli con up id team0.0
# port eth5 is visible in `teamdctl nm-team config dump`
4. nmcli con down id team0.0

Actual results:
port eth5 is still visible in `teamdctl nm-team config dump`

Expected results:
port eth5 it should no longer be in teamd config

Comment 1 Beniamino Galvani 2019-09-27 07:49:21 UTC
Fix at: 

https://gitlab.freedesktop.org/NetworkManager/NetworkManager/merge_requests/293

Note that we can set an empty configuration for the port, but it's not possible to completely remove the node from the configuration because of a limitation in the teamd API:

{
    "device": "nm-team",
    "mcast_rejoin": {
        "count": 1
    },
    "notify_peers": {
        "count": 1
    },
    "ports": {
        "eth5": {}
    },
    "runner": {
        "name": "activebackup"
    }
}

Comment 3 Vladimir Benes 2020-02-10 16:35:21 UTC
Test case added:
team_port_multiple_slaves

Comment 5 errata-xmlrpc 2020-04-28 16:53:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1847


Note You need to log in before you can comment on or make changes to this bug.