Bug 1755609 - Uninstallable with default C8 repos + EPEL
Summary: Uninstallable with default C8 repos + EPEL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: wxGTK3
Version: epel8
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Scott Talbert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-25 19:57 UTC by Lauri Nurmi
Modified: 2019-10-16 16:44 UTC (History)
4 users (show)

Fixed In Version: wxGTK3-3.0.4-11.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 16:44:26 UTC
Type: Bug


Attachments (Terms of Use)

Description Lauri Nurmi 2019-09-25 19:57:27 UTC
Description of problem:
wxGTK3 and its subpackages fail to install due to missing dependencies when only EPEL and the default CentOS 8 repos are enabled.


Version-Release number of selected component (if applicable):
3.0.4-10.el8

How reproducible:
Very

Steps to Reproduce:
1. Install clean CentOS 8
2. Run "yum install epel-release"
3. Run "yum install wxGTK3"

Actual results:
Error:
 Problem: conflicting requests
  - nothing provides libSDL2-2.0.so.0()(64bit) needed by wxGTK3-3.0.4-10.el8.1.x86_64

Expected results:
The package gets installed.

Additional info:
The main package wxGTK3 has only one missing dependency, but e.g. wxGTK3-devel is missing many more. All the missing dependencies are found if one enables the 'PowerTools' repo.

Comment 1 Scott Talbert 2019-09-25 20:06:23 UTC
Do you have any suggestions as to what we should/could do about this?

Comment 2 Lauri Nurmi 2019-09-25 20:24:07 UTC
Good news: Even though trying to install wxGTK3-devel outputs many more lines of errors, the only missing package is ultimately SDL2. In that case the solution would be either providing SDL2 in EPEL too (is it a bad idea to have it in two different repos?), or compile wx without SDL. If I'm not mistaken, wx only uses SDL for outputting sound, and I suspect wxSound is not a very widely used API for sound.

Comment 3 Fedora Update System 2019-10-01 14:30:27 UTC
FEDORA-EPEL-2019-e9b37933f7 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-e9b37933f7

Comment 4 Fedora Update System 2019-10-02 03:19:04 UTC
wxGTK3-3.0.4-11.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-e9b37933f7

Comment 5 Fedora Update System 2019-10-16 16:44:26 UTC
wxGTK3-3.0.4-11.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.