Bug 1755699 - "Add Capacity" workflow for OCS breaks Portworx Operator
Summary: "Add Capacity" workflow for OCS breaks Portworx Operator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.3.0
Assignee: Kanika Murarka
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks: 1755980
TreeView+ depends on / blocked
 
Reported: 2019-09-26 05:29 UTC by umanga
Modified: 2020-05-13 21:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1755980 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:25:21 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot from Portworx for "Add Capacity" (88.50 KB, image/png)
2019-09-26 05:29 UTC, umanga
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2840 'None' closed Bug 1755699: Removes Add capacity option for other storage operators 2020-05-15 09:55:51 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-05-13 21:25:24 UTC

Description umanga 2019-09-26 05:29:53 UTC
Created attachment 1619356 [details]
Screenshot from Portworx for "Add Capacity"

Description of problem:
When I install portworx operator and ocs operator, the expand workflow meant only for ocs operator is available even for portworx due to same "StorageCluster" Kind used by CRD of both operators. This lets Portworx users to trigger Expansion but it fails with an error saying "OCS StorageCluster is not available."


Version-Release number of selected component (if applicable):
OCS 4.2 - latest
OCP 4.2 - latest nightly builds

How reproducible:


Steps to Reproduce:
1. Install OCS Operator
2. Install Portworx Operator
3. Create StorageCluster for Portworx
4. In the instance listing page, "Add Capacity" from the kebab menu

Actual results:
"Add Capacity" is available for Portworx.
Portworx StorageClass can be used to expand Portworx.

Expected results:
"Add Capacity" should not be available for Portworx.

Additional info:

Comment 1 Nishanth Thomas 2019-09-26 06:40:27 UTC
@Sam, Please review and I think this needs to get into 4.2
We will send a patch soon

Comment 7 errata-xmlrpc 2020-05-13 21:25:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.