Bug 175574 - ExclusiveArch too restrictive
ExclusiveArch too restrictive
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hdparm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-12 17:29 EST by Moritz Barsnick
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-13 09:11:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moritz Barsnick 2005-12-12 17:29:22 EST
Description of problem:
"ExclusiveArch: i386 x86_64" prevents building hdparm for i586 or i686

Version-Release number of selected component (if applicable):
6.3-1.1

How reproducible:
always

Steps to Reproduce:
1. rpmbuild --rebuild --target=i686 hdparm-6.3-1.1.src.rpm
  
Actual results:
error: Architecture is not included: i686

Expected results:
(builds correctly for i686)

Additional info:
I didn't find any assembler code or the likes. I realize that hdparm may have 
been written for x86, and therefore shouldn't compile on e.g. ppc. But I have 
yet to see hdparm not work when compiled for i686.

Unless I oversaw something, my recommendation is either
a) expand ExclusiveArch
or
b) use ExcludeArch
Comment 1 Karsten Hopp 2005-12-13 09:11:38 EST
Compiling a package as i686 makes sense only for a few, selected packages,
hdparm definitely isn't one of them. Transfer rates won't get up just because
the hdparm binary is faster...

Note You need to log in before you can comment on or make changes to this bug.