Bug 175587 - cursor themes not working for x86_64
cursor themes not working for x86_64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-12 20:34 EST by Sammy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-11 12:34:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sammy 2005-12-12 20:34:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051211 Fedora/1.5-1.1 Firefox/1.5

Description of problem:
X cursor themes defined through default inherited theme under /usr/share/icons
are not working for gtk applications for x86_64 systems. The theme is working
fine for KDE and X11 applications. It is also working fine for gtk applications
for i386 systems.

Version-Release number of selected component (if applicable):
gtk2-2.8.9-1.1

How reproducible:
Always

Steps to Reproduce:
1. Create a default cursor theme on a x86_64 system
2. Observe that theme is working fine for all but gtk applications
3.
  

Additional info:
Comment 1 Sammy 2005-12-13 15:23:56 EST
Some more info: theme is not working for i386 applications running on x86_64.
If you build a 64 bit version of the application is does work.

It would be nice to figure out why i386 applications are not picking up the
default theme. This does not work even if I set it using the gconf-editor.
I need some things as i386 due to plugins/codecs e.g. sound applications and
firefox (the 64 bit version cannot use most of the plugins).

Comment 2 Matthias Clasen 2005-12-19 12:29:57 EST
Does changing the cursor theme in the mouse capplet work ?
Comment 3 Sammy 2005-12-19 16:11:57 EST
Is this the same as using the gconf-editor? I am using KDE. 
Comment 4 Matthias Clasen 2005-12-21 08:39:08 EST
yes, using gconf-editor to change /desktop/gnome/peripherals/cursor-theme
Comment 5 Matthias Clasen 2006-02-03 10:39:32 EST
can you try if they start working if you install libXcursor-devel ?
Comment 6 Sammy 2006-02-03 12:07:03 EST
Yes, installing the libXcursor-devel i386 on x86_64 solves the problem.
So, i386 applications on x86_64 are going for libXcursor.so rather
than libXcursor.so.x explicitly. Of course one should not install i386 devel
package on x86_64.
Comment 7 Matthias Clasen 2006-03-11 12:34:48 EST
Should be fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.