Bug 175588 - Segmentation fault when opening registers
Segmentation fault when opening registers
Status: CLOSED DUPLICATE of bug 175669
Product: Fedora
Classification: Fedora
Component: gnome-libs (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: 175669
  Show dependency treegraph
 
Reported: 2005-12-12 20:36 EST by Brian Gerst
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-14 14:26:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Gerst 2005-12-12 20:36:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051211 Fedora/1.5-1.1 Firefox/1.5

Description of problem:
After today's updates gnucash segfaults when opening any of the registers.

Version-Release number of selected component (if applicable):
gnucash-1.8.11-4

How reproducible:
Always

Steps to Reproduce:
1. Start gnucash
2. Open an account register
3. Bug buddy starts with a backtrace
  

Actual Results:  Segfault.

Expected Results:  No segfault.

Additional info:

Backtrace was generated from '/usr/bin/guile'

Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 46912499088688 (LWP 16270)]
0x00000039b5f93235 in __libc_waitpid (pid=16272, stat_loc=0x7fffffb3547c, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:32
32	      return INLINE_SYSCALL (wait4, 4, pid, stat_loc, options, NULL);
#0  0x00000039b5f93235 in __libc_waitpid (pid=16272, stat_loc=0x7fffffb3547c, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:32
#1  0x00002aaaabf4c6f0 in gnome_segv_handle (signum=11) at gnome-init.c:737
#2  <signal handler called>
#3  0x00002aaaabf0c8a6 in uta_union_clip (uta1=0xa0d430, uta2=0x0, clip=) at gnome-canvas.c:3752
#4  0x00002aaaabf0e250 in gnome_canvas_request_redraw_uta (canvas=0xb16170, uta=0xa0d430) at gnome-canvas.c:3843
#5  0x00002aaaabf0e49c in gnome_canvas_request_redraw (canvas=0xb16170, x1=0, y1=0, x2=1, y2=1) at gnome-canvas.c:3894
#6  0x00002aaaabf11ee1 in gnome_canvas_item_set_valist (item=0xb05e00, first_arg_name=0x2aaaabf783be "outline_color_gdk", args=)
    at gnome-canvas.c:602
#7  0x00002aaaabf1200b in gnome_canvas_item_set (item=) at gnome-canvas.c:564
#8  0x00002aaaabf37004 in gnome_druid_page_start_set_bg_color (druid_page_start=0x9634e0, color=) at gnome-druid-page-start.c:363
#9  0x00002aaaad128772 in gnc_druid_set_colors (druid=) at druid-utils.c:149
#10 0x00002aaaab4d811a in gnc_ui_hierarchy_druid () at druid-hierarchy.c:991
#11 0x00002aaaab177c6f in gw__tmp789_gnc_ui_hierarchy_druid_wrapper () at gw-gnc.c:161
#12 0x00002aaaaaae615b in scm_deval (x=) at eval.c:2732
#13 0x00002aaaaaae3067 in scm_deval (x=) at eval.c:2017
#14 0x00002aaaaaae6ced in scm_dapply (proc=) at eval.c:3655
#15 0x00002aaaab868c1c in gnc_file_new () at gnc-file.c:295
#16 0x00002aaaab4e7af4 in gnc_main_window_file_new_file_cb (widget=) at window-main.c:410
#17 0x00002aaaac3c3729 in gtk_signal_handler_block () from /usr/lib64/libgtk-1.2.so.0
#18 0x00002aaaac3c5c18 in gtk_signal_new () from /usr/lib64/libgtk-1.2.so.0
#19 0x00002aaaac3c6326 in gtk_signal_emit () from /usr/lib64/libgtk-1.2.so.0
#20 0x00002aaaac3f917e in gtk_widget_activate () from /usr/lib64/libgtk-1.2.so.0
#21 0x00002aaaac39d97a in gtk_menu_shell_activate_item () from /usr/lib64/libgtk-1.2.so.0
#22 0x00002aaaac39ec8b in gtk_menu_shell_append () from /usr/lib64/libgtk-1.2.so.0
#23 0x00002aaaac396707 in gtk_marshal_BOOL__POINTER () from /usr/lib64/libgtk-1.2.so.0
#24 0x00002aaaac3c5b3e in gtk_signal_new () from /usr/lib64/libgtk-1.2.so.0
#25 0x00002aaaac3c6326 in gtk_signal_emit () from /usr/lib64/libgtk-1.2.so.0
#26 0x00002aaaac3f93b1 in gtk_widget_event () from /usr/lib64/libgtk-1.2.so.0
#27 0x00002aaaac394f30 in gtk_propagate_event () from /usr/lib64/libgtk-1.2.so.0
#28 0x00002aaaac395afa in gtk_main_do_event () from /usr/lib64/libgtk-1.2.so.0
#29 0x00002aaaac5684e2 in gdk_events_init () from /usr/lib64/libgdk-1.2.so.0
#30 0x00002aaaab38e002 in g_main_add_poll () from /usr/lib64/libglib-1.2.so.0
#31 0x00002aaaab38e6f2 in g_get_current_time () from /usr/lib64/libglib-1.2.so.0
#32 0x00002aaaab38e97a in g_main_run () from /usr/lib64/libglib-1.2.so.0
#33 0x00002aaaac395fa1 in gtk_main () from /usr/lib64/libgtk-1.2.so.0
#34 0x00002aaaab4e470f in gnc_ui_start_event_loop () at top-level.c:538
#35 0x00002aaaab177d09 in gw__tmp797_gnc_ui_start_event_loop_wrapper () at gw-gnc.c:276
#36 0x00002aaaaaadfdef in scm_ceval (x=0x2aaaaf5b6cc0, env=0x2aaaaf5c20b0) at eval.c:2732
#37 0x00002aaaaaadf28f in scm_ceval (x=) at eval.c:2017
#38 0x00002aaaaaadf28f in scm_ceval (x=) at eval.c:2017
#39 0x00002aaaaaadf1bc in scm_ceval (x=) at eval.c:1987
#40 0x00002aaaaaad874d in scm_internal_dynamic_wind (before=) at dynwind.c:168
#41 0x00002aaaaab0dbd8 in scm_shell (argc=5, argv=0x7fffffb37348) at script.c:680
#42 0x00002aaaaaaf5d78 in scm_boot_guile (argc=5, argv=0x7fffffb37348, main_func=0x400af3 <inner_main>, closure=0x0) at init.c:635
#43 0x0000000000400ae9 in main (argc=5, argv=0x7fffffb37348) at guile.c:95

Thread 1 (Thread 46912499088688 (LWP 16270)):
#0  0x00000039b5f93235 in __libc_waitpid (pid=16272, stat_loc=0x7fffffb3547c, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:32
	oldtype =
Comment 1 Brian Gerst 2005-12-12 23:42:04 EST
Info printed on stderr:

Gtk-WARNING **: invalid cast from (NULL) pointer to `GtkProgress'

Gtk-CRITICAL **: file gtkprogress.c: line 493 (gtk_progress_configure):
assertion `progress != NULL' failed.
Variable "clip" is not available.
Variable "table" is not available.
Variable "ledger" is not available.
Variable "account" is not available.
Variable "user_data" is not available.
Variable "event" is not available.
Variable "x" is not available.
Variable "x" is not available.
Variable "x" is not available.
Variable "before" is not available.
Variable "oldtype" is not available.
Comment 2 Bill Nottingham 2005-12-13 15:47:53 EST
Heh, the gnome2 canvas is broken in the exact same place.
Comment 3 Brian Gerst 2005-12-14 10:33:54 EST
Still broken with libgnomecanvas-2.12.0-1.2
Comment 4 Bill Nottingham 2005-12-14 14:26:27 EST
Closing as a dup of the gcc bug. May rebuild with -O1 for the time being.

*** This bug has been marked as a duplicate of 175669 ***

Note You need to log in before you can comment on or make changes to this bug.