Bug 175595 - Suggestion for makewhatis and rpm
Suggestion for makewhatis and rpm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-13 00:07 EST by JW
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-13 10:29:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description JW 2005-12-13 00:07:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; MSIE 6.0; Windows; U; AIIEEEE!; Win98; Windows 98; en-US; Gecko masquerading as IE; should it matter?; rv:1.8b) Gecko/20050217

Description of problem:
This is just a suggested enhancement to 'makewhatis'.
Instead of initializing the whatis database with:

     cp /dev/null $whatisdb

how about:

       # Initialize with summary data from rpm packages
       rpm --dbpath /usr/lib/rpmdb/redhat -qa --queryformat '%-19{NAME} (rpm) - %{SUMMARY}\r' | tr -d '\n' | tr '\r' '\n' >$whatisdb

The \r is used so as to preserve \n's in summary.

There used to be a complete rpm database of all packages but it seems to have disappeared recently.  Anyhow it can be easily created with:

     find xxx -name \*.rpm -exec rpm --dbpath /usr/lib/rpmdb/redhat --justdb -i --nodeps '{}' ';'

Some people might find it useful because it helps tie in rpm database to apropos/man -k.


Version-Release number of selected component (if applicable):
man-1.5p-4

How reproducible:
Always

Steps to Reproduce:
1.n/a
2.
3.
  

Additional info:
Comment 1 Ivana Varekova 2005-12-13 10:29:15 EST
Thank you for your report.
I think this feature is quite useful. It is in the last man package now
(man-1.6b-2).

Note You need to log in before you can comment on or make changes to this bug.