Bug 175603 - Evolution LDAP auto-completion causes hang
Evolution LDAP auto-completion causes hang
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-13 04:25 EST by Duncan Innes
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 08:57:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Duncan Innes 2005-12-13 04:25:43 EST
Description of problem: Have configured Evolution to use IMAP, SMTP and LDAP
server for network mailbox.  Configurations are exactly the same as for a fully
working setup under RHEL 4 and Fedore Core 4.

Autocompletion is turned ON for the LDAP server only in all cases.

When entering part of an address under the FC5test1 installation,
evolution-data-server goes into a 100% CPU loop (I don't know how to figure out
how it's getting into that state I'm afraid - sorry).

As it stands, it's been in the loop for 10 minutes.

The first time this happened, I had the Contacts application as well and it came
up with the crash window for evolution-data-server, but the window was
un-responsive so I couldn't fill out a bug.


Version-Release number of selected component (if applicable): 1.4.1.1-1


How reproducible: Happens every time I try to get an auto-completion to work


Steps to Reproduce:
1. Set up Evolution with IMAP, SMTP and LDAP servers
2. Turn autocompletion ON for LDAP server and OFF for local server
3. Create new mail and type part of an address in
  
Actual results:
The Evolution and Compose a message windows become unresponsive and don't
re-draw, and the evolution-data-server process starts taking 100% CPU time.

Expected results:
Expected address to be auto-completed from a list of possible matches from the
LDAP server.

Additional info: As stated above, identical setups work perfectly well under
Fedora Core 4 (fresh install with no updates) and RHEL 4 WS (fresh install with
updates from RHEL Satellite server).
Comment 1 Duncan Innes 2006-02-05 06:01:09 EST
Trying to wake this bug up as it would be a shame for it to go out in this state.

Finding that the bug does actually exist on Fedora Core 4 also.

Main work desktop is a Fedora Core 4 machine.  Machine uses 100% CPU after
sending  an e-mail - always caused by evolution-data-server.  It is then also
impossible to send an e-mail using the LDAP address book. Killing the
evolution-data-server process solves the CPU usage issue, and allows the LDAP
address book to be used.
Comment 2 Rahul Sundaram 2006-02-20 06:22:12 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 4 Duncan Innes 2006-08-14 08:57:54 EDT
Closing as NOTABUG as I am no longer in a position to test this.

I think it was still an issue when FC5 was released, but the memory is distant.

No longer working for a company with this kind of mail config.

Note You need to log in before you can comment on or make changes to this bug.