Bug 1756107 - must-gather should log errors as warnings if script can not gather information from certain operator pods
Summary: must-gather should log errors as warnings if script can not gather informatio...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
: 1755414 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-26 19:07 UTC by Hemant Kumar
Modified: 2020-05-13 21:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:25:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 113 None closed Bug 1756107: Make container endpoint collection errors non-fatal 2020-03-23 16:28:36 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-05-13 21:25:30 UTC

Comment 1 Michal Fojtik 2019-09-30 09:13:13 UTC
*** Bug 1755414 has been marked as a duplicate of this bug. ***

Comment 4 zhou ying 2019-10-15 09:19:10 UTC
Confirmed with latest version , now will print information like:
[root@dhcp-140-138 ~]# oc version
Client Version: v4.3.0
Server Version: 4.3.0-0.nightly-2019-10-15-020113
Kubernetes Version: v1.16.0-beta.2+a6ff814


[must-gather-nrh57] POD I1015 08:37:18.574427      45 log.go:172]         Unable to gather previous container logs: previous terminated container "operator" in pod "authentication-operator-56d6bc9db8-6l5lg" not found
[must-gather-nrh57] POD I1015 08:37:18.574460      45 log.go:172]         Skipping container endpoint collection for pod "authentication-operator-56d6bc9db8-6l5lg" container "operator": No ports

Comment 6 errata-xmlrpc 2020-05-13 21:25:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.