Bug 175611 - Enable Serbian language for installation
Enable Serbian language for installation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-13 07:10 EST by Miloš Komarčević
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 13:26:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloš Komarčević 2005-12-13 07:10:06 EST
Please add Serbian to the list of supported languages during installation.

The locale(s) for Serbian are

sr_CS.UTF-8 (default, cyrillic script)
sr_CS.UTF-8@Latn (po files not yet available in CVS, still awaiting to be added
to ACL)

More info on these locales can be found here if needed:
http://srpski.org/locale/

The keyboard for sr_CS is "srp" in XKB. The latin locale sr_CS@Latn uses
"srp(latin)".

The timezone for Serbia and Montenegro is GMT+0100.
Comment 1 Jeremy Katz 2005-12-19 13:19:54 EST
Having users select the script that they use is absurd -- most users won't and
don't care to know the difference.  Given the translation status, I'm okay with
adding Serbian, but only one.  Which is the one that is going to be preferred by
most users and the "best" for them to use?
Comment 2 Igor Miletic 2005-12-19 13:30:06 EST
Cyrillic is the preferred script and main script for Serbian language.

However, both are official scripts and historically both are used. 

You should consider adding both not because Milos or I like it that way, but
because whole political situation in last couple of decades had made it such
that some people can read only latin script and other only cyrillic ( there is
so much to say about having two scripts, but this is really not place for that). 

I know that this sounds absurd to you, but for us it is necessity for many reasons.
Comment 3 Jeremy Katz 2005-12-19 15:41:41 EST
I'm mostly concerned about user confusion.  How do they differentiate that they
want one vs the other?  
Comment 4 Igor Miletic 2005-12-19 16:31:20 EST
The difference is obvious to any Serbian speaking person (i.e. we are all aware
of  both scripts). 

Example of two scripts (same sentence) is given below, first cyrillic then latin
and then English translation (you must use UTF-8 encoding to see them).
Ово је реченица писана на српском.
Ovo je rečenica pisana na srpskom.
This sentence is written in Serbian (language).

I do not know if my word is worth anything, but there will be no confusion. Only
people that will want to use Serbian language (i.e. Serbs, Montenegrians etc.)
are aware that we use two scripts and that one looks like English script and
other like Russian.

It is people of Serbian descent that are born in western countries that would
preffer latin (and most likely would only know latin script) while people born
in Serbia would use exclusively cyrillic script (in general). Also, regions in
Serbia and neighbouring countries that use Serbian language might preffer latin
script as well.

Well, closest to real life example of this confusion might be Cantonese and
Mandarin dialects. They use same script for two dialects. We use two scripts for
one language :).

If you wonder how to name them, one called Serbian would default to cyrillic,
other could be called Serbian(Latin).
Comment 5 Miloš Komarčević 2005-12-19 22:01:15 EST
Jeremy, as Igor, I also do understand why this is confusing and seems absurd to
people not knowing how this situation came about. Igor explained it sufficiently
well, but maybe the following reading will help further

http://en.wikipedia.org/wiki/Serbian_language
http://en.wikipedia.org/wiki/Serbo-Croatian_language

Bottom line is, wether we like it or not, that's just how things are on the
ground, as with traditional and simplified Chinese for example. We _absolutely_
have to support both scripts as they are equally used by Serbian speakers all
over the world. As you can see from the glyphs, the two cannot be confused, and
the labels when choosing one can the ones Igor suggested.  

Before Unicode, supporting latin only was easier so cyrillic was completely
neglected (unlike Russians and Bulgarians who worked hard on cyrillic support as
that's the only script they use, and I guess our predecessors took the easy way
out with latin), but luckily we don't have to do that any more.

To support only one (any of the two) will come off very unprofessional and a
half-hearted attempt, not to mention fuel already existing political debates
between people prefering one or the other (trust me, you don't want to touch
that one with a mile long pole), and that is why we do not have a luxury to make
a preference. Besides, GNOME supports both, KDE supports both, as do most other
projects, even Windoze. There is no reason for Fedora/RHEL not to support both.

We have the sr@Latn .po files ready to go (we maintain the translations in
cyrillic and simply make the latin ones by means of a script), but we can't
commit them to the CVS as our requests on fedora-trans-list have so far been
falling on deaf ears:

https://www.redhat.com/archives/fedora-trans-list/2005-November/msg00012.html
https://www.redhat.com/archives/fedora-trans-list/2005-December/msg00005.html

Since I just saw test2 has been pushed back, let's please try to figure out the
best way how to handle this? As mentioned, we only need to keep track of the
cyrillic translation on the statistics page as the other one is generated
automatically and will always have the same status. We just need have both sr
and sr@Latn in ACL to be able to commit. Maybe you can check how the GNOME
project implemented this duality? 

Thanks a lot for working with us on this one.
Comment 6 Jeremy Katz 2005-12-22 12:02:21 EST
*sigh*  I still don't like it, but added them to anaconda's list.  As for
getting the translation stuff added, if you're not getting a response on
fedora-trans, send mail directly to sarahs and bgroh AT redhat DOT com
Comment 7 Miloš Komarčević 2006-01-18 05:00:35 EST
Just tested installation of fc5test2 in Serbian, it works well for the most
part, thanks.

A few things need to be polished though:

- Language selection: Serbian(Latin) does not appear to be enabled (I guess this
is because sr@Latn.po didn't appaer until after the test2 freeze date)

- Language selection: string for "Serbian" not translated (I guess not really a
problem because anaconda.pot got updated after the test2 translation freeze
date, should appear in the next version, same for "Serbian(Latin)" when it gets
added to anaconda.pot)

- Keyboard selection: Strings for "Serbian" and "Serbian(Latin)" not translated
(couldn't find these in anaconda.pot; I guess rhpl.pot is used for this, but
these two are not there either, need to be added)

- Timezone selection: please set existing "Europe/Belgrade" as the default location

- Timezone selection: none of the location strings are translated at all,
although system-config-date/timezones translations for sr and sr@Latn exist
Comment 8 Jeremy Katz 2006-01-18 13:26:47 EST
Yeah, the po files didn't quite make it in time.  I'll add it back now and the
strings should show up in the pot files (and then get translated) fine.  Also
changed the default timezone.

For the timezone location strings, can you file a separate bug so that it can
get looked at appropriately?

Note You need to log in before you can comment on or make changes to this bug.