Bug 1756123 - Project admin can't access metrics - no RBAC policy matched
Summary: Project admin can't access metrics - no RBAC policy matched
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 3.11.0
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.11.z
Assignee: Frederic Branczyk
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-26 20:02 UTC by Matthew Robson
Modified: 2019-11-18 14:52 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-18 14:52:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3817 0 None None None 2019-11-18 14:52:21 UTC

Description Matthew Robson 2019-09-26 20:02:40 UTC
Description of problem:

oc adm top pod

Error from server (Forbidden): pods.metrics.k8s.io is forbidden: User "metrics-test" cannot list pods.metrics.k8s.io in the namespace "metrics-test": no RBAC policy matched

Upstream metrics-server added an aggregated reader cluster role for this purpose:

https://github.com/kubernetes-incubator/metrics-server/pull/149/files


Version-Release number of selected component (if applicable):

3.11

How reproducible:

oc adm top pod as a project admin


Steps to Reproduce:
1.
2.
3.

Actual results:

Error from server (Forbidden): pods.metrics.k8s.io is forbidden: User "metrics-test" cannot list pods.metrics.k8s.io in the namespace "metrics-test": no RBAC policy matched


Expected results:

Project admin should be able to see metrics from project.


Additional info:

Comment 6 Frederic Branczyk 2019-10-23 09:10:31 UTC
https://github.com/openshift/openshift-ansible/pull/11978 was merged to setting status to modified.

Comment 10 errata-xmlrpc 2019-11-18 14:52:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3817


Note You need to log in before you can comment on or make changes to this bug.