This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 175620 - Loading new certificate with rhn-satellite-activate has no effect
Loading new certificate with rhn-satellite-activate has no effect
Status: CLOSED DUPLICATE of bug 171160
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
400
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Vlady Zlatkin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-13 09:02 EST by Carsten Clasohm
Modified: 2007-07-31 11:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-23 21:43:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carsten Clasohm 2005-12-13 09:02:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
During a Satellite evaluation, one of our customers received a new Satellite certificate with an increased number of channel entitlements. Following the documentation in section 5.3 of "RHN Satellite Server 4.0: Installation Guide", I used rhn-satellite-activate to activate the Satellite.

rhn-satellite-activate did not report any errors, but the entitlement counts on /network/software/channels/entitlements.pxt did not change. 


Version-Release number of selected component (if applicable):
rhns-satellite-tools-4.0.3-3.rhel4

How reproducible:
Always

Steps to Reproduce:
1. Set up a connected Satellite with a valid certificate.
2. rhn-satellite-activate --sanity-only --rhn-cert=foo-4.cert
3. rhn-satellite-activate --rhn-cert=foo-4.cert


Actual Results:  The entitlement counts on /network/software/channels/entitlements.pxt do not change. Restarting the Satellite Server doesn't help. Only uploading the new certificate to rhn.redhat.com and running satellite-sync on the Satellite updates the entitlement counts.


Expected Results:  rhn-satellite-activate should update the entitlement counts.


Additional info:

If this also happens on a disconnected Satellite, it would be a more serious bug, as there you would not be able to update the certificate with satellite-sync.
Comment 1 Clifford Perry 2006-08-23 21:43:45 EDT
This has been resolved with the RHN 410 Satellite release. This is a duplicate
of bug 171160 – rhn-satellite-activate does not update channel entitlements. 

For disconnected Satellite, the solution would be to establish some type of
channel dump ISO directory/mount point to point Satellite sync to and then use
command syntax:

satellite-sync --mount-point=./path/to/mount --rhn-cert=/path/to/cert

Cliff. 

*** This bug has been marked as a duplicate of 171160 ***

Note You need to log in before you can comment on or make changes to this bug.