Bug 175621 - Missing dependencies for texdoctk
Summary: Missing dependencies for texdoctk
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-13 14:35 UTC by James Bannon
Modified: 2013-07-02 23:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-16 15:51:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Bannon 2005-12-13 14:35:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
There seem to be missing dependencies for texdoctk. Specifically, running it requires perl-Tk which is not installed as part of the core distribution. The fix is easy 'yum install tetex-doc perl-Tk' but I think this is technically a dependency problem.

Version-Release number of selected component (if applicable):
tetex-3.0-7.FC4.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. Install the Fedora Core
2. try running texdoctk from the command line
3.
  

Actual Results:  texdoctk complained that it needed perl-Tk to run.

Additional info:

Comment 1 Jindrich Novy 2005-12-16 15:51:52 UTC
Since perl-Tk isn't a part of core distribution, texdoctk will complain when
perl-Tk isn't installed and runs fine otherwise. If perl-Tk isn't present then I
added a message that instruct an user to install perl-Tk from Extras, so there's
no need to add the dependency explicitely and perl-Tk to Core as texdoctk isn't
an essential teTeX utility.

For reference please see bug 162441.


Note You need to log in before you can comment on or make changes to this bug.