Bug 1756230 - Configmaps not loading from web-console
Summary: Configmaps not loading from web-console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.11.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-27 06:56 UTC by Jaspreet Kaur
Modified: 2020-07-02 07:05 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-18 14:52:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin-web-console pull 3152 0 'None' closed Bug 1756230: Only load config map metadata on config maps page 2020-07-01 15:42:25 UTC
Red Hat Product Errata RHBA-2019:3817 0 None None None 2019-11-18 14:52:21 UTC

Description Jaspreet Kaur 2019-09-27 06:56:40 UTC
Description of problem: It has been observed that configmaps of some projects are not able to load from web-console while for other project it is working fine. Also, it doesnt load from one region say India but works from other country. It has also been seen that it works perfectly fine from cli




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Go to webconsole
2. Move to the project 
3. Access the configmap. It gives error dialogue i.e

Failed to list configmaps

Actual results: "Failed to list configmaps" only for some projects


Expected results: Should not have an issue.


Checked the logs but nothing is evident in the logs.


Additional info:

Comment 5 Ilan Green 2019-10-03 09:50:06 UTC
Created attachment 1622235 [details]
after pressing sources and scripts in chrome debug mode

When running chrome in debug mode ctrl+shift+i
after pressing sources and scripts on the left hand

Comment 13 Samuel Padgett 2019-10-14 13:56:07 UTC
The following change greatly reduces the size of the response on the web console config maps page by only loading resource metadata. This will avoid loading the config maps content, which isn't needed on the list page, and greatly improve performance over slow network connections.

https://github.com/openshift/origin-web-console/pull/3152

Note that using `oc apply` on config maps will duplicate the config map data as an annotation, roughly doubling the size. If you use `oc apply`, the response might still be large for many config maps, although this change should still reduce it by about half.

Comment 18 XiaochuanWang 2019-11-06 08:00:40 UTC
Display correctly, mark it as Verified.
Tested on v3.11.154

Comment 21 errata-xmlrpc 2019-11-18 14:52:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3817


Note You need to log in before you can comment on or make changes to this bug.