Bug 1756288 - blivet.errors.PartitioningError: Unable to allocate requested partition scheme.
Summary: blivet.errors.PartitioningError: Unable to allocate requested partition scheme.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: blivet-gui
Version: 31
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vojtech Trefny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b0e41a0637b22cd0722b92ec2b4...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-27 09:31 UTC by lnie
Modified: 2020-02-15 02:54 UTC (History)
9 users (show)

Fixed In Version: blivet-gui-2.1.12-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-02 01:35:00 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (1.34 MB, text/plain)
2019-09-27 09:35 UTC, lnie
no flags Details
File: anaconda.log (34.32 KB, text/plain)
2019-09-27 09:35 UTC, lnie
no flags Details
File: blivet-gui-utils.log (18.42 KB, text/plain)
2019-09-27 09:35 UTC, lnie
no flags Details
File: dbus.log (2.92 KB, text/plain)
2019-09-27 09:35 UTC, lnie
no flags Details
File: environ (637 bytes, text/plain)
2019-09-27 09:35 UTC, lnie
no flags Details
File: lorax-packages.log (25.23 KB, text/plain)
2019-09-27 09:35 UTC, lnie
no flags Details

Description lnie 2019-09-27 09:31:34 UTC
Version-Release number of selected component:
anaconda-31.22.3

The following was filed automatically by anaconda:
anaconda 31.22.3 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.7/site-packages/blivetgui/blivetgui.py", line 232, in _reraise_exception
    raise type(exception)(str(exception) + "\n" + traceback)
  File "/usr/lib/python3.7/site-packages/blivetgui/blivetgui.py", line 470, in add_device
    self._reraise_exception(result.exception, result.traceback)
blivet.errors.PartitioningError: Unable to allocate requested partition scheme.
Traceback (most recent call last):
  File "/usr/lib/python3.7/site-packages/blivetgui/blivet_utils.py", line 1188, in add_device
    blivet.partitioning.do_partitioning(self.storage)
  File "/usr/lib/python3.7/site-packages/blivet/partitioning.py", line 608, in do_partitioning
    allocate_partitions(storage, disks, partitions, free, boot_disk=boot_disk)
  File "/usr/lib/python3.7/site-packages/blivet/partitioning.py", line 950, in allocate_partitions
    raise PartitioningError(_("Unable to allocate requested partition scheme."))
blivet.errors.PartitioningError: Unable to allocate requested partition scheme.


Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-dvd-x86_64-31 rd.live.check quiet
dnf.librepo.log: 
executable:     /sbin/anaconda
hashmarkername: anaconda
hawkey.log:     INFO Sep-27 07:14:40 === Started libdnf-0.35.3 ===
kernel:         5.3.0-0.rc6.git0.1.fc31.x86_64
product:        Fedora
release:        Fedora release 31 (Thirty One)
release_type:   pre-release
type:           anaconda
version:        31

Potential duplicate: bug 1442020

Comment 1 lnie 2019-09-27 09:35:32 UTC
Created attachment 1619977 [details]
File: anaconda-tb

Comment 2 lnie 2019-09-27 09:35:39 UTC
Created attachment 1619978 [details]
File: anaconda.log

Comment 3 lnie 2019-09-27 09:35:42 UTC
Created attachment 1619979 [details]
File: blivet-gui-utils.log

Comment 4 lnie 2019-09-27 09:35:45 UTC
Created attachment 1619980 [details]
File: dbus.log

Comment 5 lnie 2019-09-27 09:35:46 UTC
Created attachment 1619981 [details]
File: environ

Comment 6 lnie 2019-09-27 09:35:52 UTC
Created attachment 1619982 [details]
File: lorax-packages.log

Comment 7 lnie 2019-09-30 04:23:16 UTC
Here is crash analysis:
Due to bug#1755813,/boot failed to take use of the beginning free region,but take use of the smaller free region,
and there is only 4.99G left for a 5.99G request, free return None, a PartitioningError is raised and due to this error is not handled in blivet-gui,
crash happened.In a non-blivetgui installation,a error dialog is present so no crash happens.
Is the intended behavior that we use the exact size user asked but not give a base_size and set grow=True like blivet do?
Even if it's the intended behavior,we should add a command like new_part.req_max_size= ... to avoid confusing log (max_size=0) like we see in #1756220.
If it's not I'd like to work on a pull request,no thanks^^
In conclusion,there are 3 ways to avoid this bug,
first is the pull request in #1755813(https://github.com/storaged-project/blivet-gui/pull/131)
second is give a base_size and send grow=True,
third is handle Error with a error log present to give user the chance to re-set the partitions

Comment 8 lnie 2019-09-30 04:26:30 UTC
Please correct me if I'm wrong,thanks a lot.

Comment 9 Fedora Update System 2020-01-29 20:27:50 UTC
FEDORA-2020-1fdbcfc43f has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-1fdbcfc43f

Comment 10 Fedora Update System 2020-01-31 01:30:03 UTC
blivet-gui-2.1.12-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-e2356a3d5e

Comment 11 Fedora Update System 2020-01-31 02:25:58 UTC
blivet-gui-2.1.12-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-1fdbcfc43f

Comment 12 Fedora Update System 2020-02-02 01:35:00 UTC
blivet-gui-2.1.12-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2020-02-15 02:54:04 UTC
blivet-gui-2.1.12-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.