Bug 1756317 - Binary stripping for cri-o fails RPMdiff
Summary: Binary stripping for cri-o fails RPMdiff
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.6.0
Assignee: Peter Hunt
QA Contact: Sunil Choudhary
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-27 11:28 UTC by Luke Meyer
Modified: 2020-10-27 15:54 UTC (History)
9 users (show)

Fixed In Version: cri-o-1.14.12-15.dev.rhaos4.2.gita17905f.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 15:54:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:54:52 UTC

Description Luke Meyer 2019-09-27 11:28:20 UTC
Description of problem:
https://rpmdiff.engineering.redhat.com/run/417179/4/

> File usr/lib/debug/usr/libexec/crio/pause-1.14.10-0.21.dev.rhaos4.2.git0d4a906.el8.s390x.debug is stripped on s390x (missing [.gdb_index .debug_info])
(and similar)

Version-Release number of selected component (if applicable):
1.14.10-0.21.dev.rhaos4.2.git0d4a906.el8
and several previous runs

Additional info:
We've been waiving these but I think incorrectly (normally the complaint is that things are NOT stripped, this is complaining that debug info IS stripped). Just want to know if this is intended and provide rationale if so.

Comment 5 Luke Meyer 2019-09-27 18:10:26 UTC
sorry, I should probably have mentioned conmon is affected too:

File usr/lib/debug/usr/libexec/crio/conmon-1.14.10-0.21.dev.rhaos4.2.git0d4a906.el8.s390x.debug is stripped on s390x (missing [.gdb_index .debug_info])

If you guys say we can ignore this for now, doesn't need to block release, that's all I really need to know. Would of course be nice to get it fixed for future updates on 4.x

Comment 18 errata-xmlrpc 2020-10-27 15:54:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.