Bug 175632 - Fedora ia64 installation build failing
Fedora ia64 installation build failing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2005-12-13 11:08 EST by Prarit Bhargava
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-29 11:40:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to re-add boot.img creation for EFI (3.75 KB, patch)
2006-01-24 12:33 EST, Prarit Bhargava
no flags Details | Diff

  None (edit)
Description Prarit Bhargava 2005-12-13 11:08:38 EST
Description of problem: 
 
Installation build failed due to  
 
Running: /tmp/treedir.23402/instimage/usr/lib/anaconda-runtime/getkeymaps 
ia64 /tmp/keymaps-ia64.2800 /tmp/treedir.23402/instimage 
unpacking /mnt/redhat/nightly/rawhide-20051213/ia64/ia64-global/Fedora/RPMS/kernel-2.6.14-1.1756_FC5.ia64.rpm.ia64 
cp: cannot stat 
`/mnt/redhat/nightly/rawhide-20051213/ia64/ia64-global/images/boot.img': No 
such file or directory 
Wrote /mnt/redhat/nightly/rawhide-20051213/ia64/ia64-global/Fedora/base/minstg2.img 
(31256k)... 
 
Version-Release number of selected component (if applicable): 
 
rawhide-20051213 
 
How reproducible: 100% 
 
 
Steps to Reproduce: 
1. 
2. 
3. 
   
Actual results: 
 
 
Expected results: 
 
 
Additional info:  I haven't looked into this at all.  Just reporting it for 
now.
Comment 1 Jeremy Katz 2005-12-19 13:26:23 EST
This is because we're not making the boot.img anymore... 

Can we create a boot.iso on ia64 that doesn't depend on the silly disk image?  I
would think that EFI could handle just a regular iso9660 filesystem, but haven't
tried.
Comment 2 Prarit Bhargava 2006-01-05 14:10:07 EST
Oops.  What I meant to say (me gud english) was: 
 
"It looks like the nightly ia64 rawhide builds are failing for some reason. 
The current boot.iso size is 34k in size which makes no sense at all.  Looks 
like the boot.img file isn't being built?" 
 
and add the rest of that. 
 
>Can we create a boot.iso on ia64 that doesn't depend on the silly disk image? 
 
Hmmm ... I'll try this out with a known good ISO and see if it works :) 
 
P. 
Comment 3 Prarit Bhargava 2006-01-10 09:58:59 EST
>Can we create a boot.iso on ia64 that doesn't depend on the silly disk image? 
 
I had never tried it and the good news it works.  I'm tracking down why 
the boot.iso is 34k in size... 
Comment 4 Prarit Bhargava 2006-01-23 14:49:20 EST
Jeremy -- I'm working on a patch to dynamically calculate the dosfs boot.img 
size and only create it in ia64.  This patch will be based off the patch in 
BZ175095. 
 
I'm wondering if it is possible that other arch's (for whatever possible  
reason) might use EFI?  (I'm not considering that for this patch ... just 
curious as to whether or not other arch's run it...) 
 
P. 
Comment 5 Prarit Bhargava 2006-01-24 12:33:54 EST
Created attachment 123619 [details]
Patch to re-add boot.img creation for EFI
Comment 6 Chris Lumens 2006-01-25 15:32:34 EST
Thanks for the patch.  Please try the next Rawhide tree with an anaconda build
(should be tomorrow's tree).

Note You need to log in before you can comment on or make changes to this bug.