Bug 1756325 - Rebalance is causing glusterfs crash on client node
Summary: Rebalance is causing glusterfs crash on client node
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribute
Version: rhgs-3.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: RHGS 3.5.0
Assignee: Nithya Balachandran
QA Contact: Sayalee
URL:
Whiteboard:
Depends On:
Blocks: 1759141 1696809 1757399 1760779 1769315 1786983 1804522
TreeView+ depends on / blocked
 
Reported: 2019-09-27 11:57 UTC by Sayalee
Modified: 2020-02-19 03:48 UTC (History)
14 users (show)

Fixed In Version: glusterfs-6.0-16
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1757399 1759141 (view as bug list)
Environment:
Last Closed: 2019-10-30 12:23:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
Cmvlt python script used as IO (7.27 KB, text/plain)
2019-09-27 11:57 UTC, Sayalee
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:3249 None None None 2019-10-30 12:23:29 UTC

Description Sayalee 2019-09-27 11:57:06 UTC
Created attachment 1620039 [details]
Cmvlt python script used as IO

Description of problem:
When on distributed-dispersed volume, add-brick and rebalance is performed with cmvlt python script (see attachment for the script) running as IO, there is glusterfs crash on the client node.

Version-Release number of selected component (if applicable):
6.0.14

How reproducible:
1/1

Steps to Reproduce:
1. Create a 3X(4+2) volume.
2. Mount the volume on a client node using FUSE.
3. On the client node, create multiple directories (in this case 5) and start running the python script simultaneously from all the 5 dirs.
4. Add bricks to the volume to convert it into 4X(4+2) and trigger rebalance.
5. Wait for the rebalance to complete.

Actual results:
* Rebalance completes successfully, without any failures.
* But on client node, there IO errors and also glusterfs crashes generating a core file.

Expected results:
There should be no IO errors and glusterfs crash on client node.

Additional info:
* For the IO errors , a bug has been raised 
  (https://bugzilla.redhat.com/show_bug.cgi?id=1744881)
* sosreports will be shared

Comment 33 errata-xmlrpc 2019-10-30 12:23:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:3249


Note You need to log in before you can comment on or make changes to this bug.